summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-09-26 17:27:47 +0000
committerJory Pratt <anarchy@gentoo.org>2010-09-26 17:27:47 +0000
commit22bae12bc570450e89eae06ed26df04881c24e55 (patch)
treede7f9a61895f463879e44be88e327267c8a141a5 /x11-plugins/enigmail
parentFixing LDFLAGS problem. (diff)
downloadgentoo-2-22bae12bc570450e89eae06ed26df04881c24e55.tar.gz
gentoo-2-22bae12bc570450e89eae06ed26df04881c24e55.tar.bz2
gentoo-2-22bae12bc570450e89eae06ed26df04881c24e55.zip
Bump enigmail to use current tb source tarball/patchset
(Portage version: 2.1.9.10/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/ChangeLog8
-rw-r--r--x11-plugins/enigmail/enigmail-1.0.1-r3.ebuild154
-rw-r--r--x11-plugins/enigmail/enigmail-1.1.2-r3.ebuild (renamed from x11-plugins/enigmail/enigmail-1.1.2-r1.ebuild)25
3 files changed, 18 insertions, 169 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
index b2e2359512d3..90c5446b335c 100644
--- a/x11-plugins/enigmail/ChangeLog
+++ b/x11-plugins/enigmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/enigmail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.203 2010/09/14 17:03:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.204 2010/09/26 17:27:47 anarchy Exp $
+
+*enigmail-1.1.2-r3 (26 Sep 2010)
+
+ 26 Sep 2010; Jory A. Pratt <anarchy@gentoo.org> -enigmail-1.0.1-r3.ebuild,
+ -enigmail-1.1.2-r1.ebuild, +enigmail-1.1.2-r3.ebuild:
+ Bump enigmail to use current tb source tarball/patchset
14 Sep 2010; Christian Faulhammer <fauli@gentoo.org>
enigmail-1.1.2-r2.ebuild:
diff --git a/x11-plugins/enigmail/enigmail-1.0.1-r3.ebuild b/x11-plugins/enigmail/enigmail-1.0.1-r3.ebuild
deleted file mode 100644
index 388e6ddac9f6..000000000000
--- a/x11-plugins/enigmail/enigmail-1.0.1-r3.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-1.0.1-r3.ebuild,v 1.7 2010/06/13 02:27:59 nirbheek Exp $
-
-WANT_AUTOCONF="2.1"
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib mozextension autotools
-MY_P="${P/_beta/b}"
-EMVER="${PV}"
-TBVER="3.0.4"
-PATCH="mozilla-thunderbird-3.0-patches-0.3"
-
-DESCRIPTION="GnuPG encryption plugin for thunderbird."
-HOMEPAGE="http://enigmail.mozdev.org"
-SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}.source.tar.bz2
- http://www.mozilla-enigmail.org/download/source/${PN}-${EMVER}.tar.gz
- http://dev.gentoo.org/~anarchy/dist/${PATCH}.tar.bz2"
-
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="MPL-1.1 GPL-2"
-IUSE="system-sqlite"
-
-DEPEND=">=mail-client/thunderbird-3.0[system-sqlite=]"
-RDEPEND="${DEPEND}
- system-sqlite? ( >=dev-db/sqlite-3.6.22-r2[fts3,secure-delete] )
- || (
- (
- >=app-crypt/gnupg-2.0
- || (
- app-crypt/pinentry[gtk]
- app-crypt/pinentry[qt4]
- )
- )
- =app-crypt/gnupg-1.4*
- )"
-
-S="${WORKDIR}"/comm-1.9.1
-
-pkg_setup() {
- # EAPI=2 ensures they are set properly.
- export BUILD_OFFICIAL=1
- export MOZILLA_OFFICIAL=1
- export MOZ_CO_PROJECT=mail
-}
-
-src_unpack() {
- unpack thunderbird-${TBVER}.source.tar.bz2 ${PATCH}.tar.bz2 || die "unpack failed"
-}
-
-src_prepare(){
- # Apply our patches
- EPATCH_EXCLUDE="106-bz466250_att349521_fix_ftbfs_with_cairo_fb.patch" \
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"
-
- cd mozilla
- eautoreconf
- cd js/src
- eautoreconf
-
- # Unpack the enigmail plugin
- cd "${S}"/mailnews/extensions || die
- unpack enigmail-${EMVER}.tar.gz
- cd "${S}"/mailnews/extensions/enigmail || die "cd failed"
- makemake2
-
- cd "${S}"
-
- # Fix installation of enigmail.js
- epatch "${FILESDIR}"/70_enigmail-fix.patch
-
- eautoreconf
-}
-
-src_configure() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- touch mail/config/mozconfig
- mozconfig_init
- mozconfig_config
-
- # tb-specific settings
- mozconfig_annotate '' \
- --with-system-nspr \
- --with-system-nss \
- --disable-wave \
- --disable-ogg \
- --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
- --with-user-appdir=.thunderbird \
- --enable-application=mail
-
- mozconfig_use_enable system-sqlite
-
- # Finalize and report settings
- mozconfig_final
-
- # Disable no-print-directory
- MAKEOPTS=${MAKEOPTS/--no-print-directory/}
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- ####################################
- #
- # Configure and build Thunderbird
- #
- ####################################
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- econf || die
-
- # This removes extraneous CFLAGS from the Makefiles to reduce RAM
- # requirements while compiling
- edit_makefiles
-}
-
-src_compile() {
- # Only build the parts necessary to support building enigmail
- emake -j1 export || die "make export failed"
- emake -C mozilla/modules/libreg || die "make modules/libreg failed"
- emake -C mozilla/xpcom/string || die "make xpcom/string failed"
- emake -C mozilla/xpcom || die "make xpcom failed"
- emake -C mozilla/xpcom/obsolete || die "make xpcom/obsolete failed"
-
- # Build the enigmail plugin
- einfo "Building Enigmail plugin..."
- emake -C "${S}"/mailnews/extensions/enigmail || die "make enigmail failed"
-
- # Package the enigmail plugin; this may be the easiest way to collect the
- # necessary files
- emake -j1 -C "${S}"/mailnews/extensions/enigmail xpi || die "make xpi failed"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
- declare emid
-
- cd "${T}"
- unzip "${S}"/mozilla/dist/bin/*.xpi install.rdf
- emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
-
- dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
- cd "${D}"${MOZILLA_FIVE_HOME}/extensions/${emid}
- unzip "${S}"/mozilla/dist/bin/*.xpi
-}
diff --git a/x11-plugins/enigmail/enigmail-1.1.2-r1.ebuild b/x11-plugins/enigmail/enigmail-1.1.2-r3.ebuild
index 5d7780f1d0fd..162bd3fdd9f3 100644
--- a/x11-plugins/enigmail/enigmail-1.1.2-r1.ebuild
+++ b/x11-plugins/enigmail/enigmail-1.1.2-r3.ebuild
@@ -1,29 +1,29 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-1.1.2-r1.ebuild,v 1.7 2010/08/10 15:56:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-1.1.2-r3.ebuild,v 1.1 2010/09/26 17:27:47 anarchy Exp $
WANT_AUTOCONF="2.1"
-EAPI="2"
+EAPI="3"
inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib mozextension autotools
MY_P="${P/_beta/b}"
EMVER="${PV}"
-TBVER="3.1"
-PATCH="mozilla-thunderbird-3.1-patches-0.1"
+TBVER="3.1.4"
+PATCH="thunderbird-3.1-patches-1.1"
DESCRIPTION="GnuPG encryption plugin for thunderbird."
HOMEPAGE="http://enigmail.mozdev.org"
REL_URI="ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/"
SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}.source.tar.bz2
http://www.mozilla-enigmail.org/download/source/${PN}-${EMVER}.tar.gz
- http://dev.gentoo.org/~anarchy/dist/${PATCH}.tar.bz2"
+ http://dev.gentoo.org/~anarchy/mozilla/patchsets/${PATCH}.tar.bz2"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="MPL-1.1 GPL-2"
IUSE="system-sqlite"
-DEPEND=">=mail-client/thunderbird-3.1_beta1[system-sqlite=]"
+DEPEND=">=mail-client/thunderbird-3.1.1-r1[system-sqlite=]"
RDEPEND="${DEPEND}
system-sqlite? ( >=dev-db/sqlite-3.6.22-r2[fts3,secure-delete] )
|| (
@@ -56,9 +56,6 @@ src_prepare(){
EPATCH_FORCE="yes" \
epatch "${WORKDIR}"
- # ARM fixes, bug 327783
- epatch "${FILESDIR}/thunderbird-xul-1.9.2-arm-fixes.patch"
-
cd mozilla
eautoreconf
cd js/src
@@ -80,7 +77,7 @@ src_prepare(){
}
src_configure() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/thunderbird"
####################################
#
@@ -98,7 +95,7 @@ src_configure() {
--with-system-nss \
--disable-wave \
--disable-ogg \
- --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-default-mozilla-five-home="${EPREFIX}"${MOZILLA_FIVE_HOME} \
--with-user-appdir=.thunderbird \
--enable-application=mail \
--disable-necko-wifi \
@@ -147,7 +144,7 @@ src_compile() {
}
src_install() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-thunderbird"
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/thunderbird"
declare emid
cd "${T}"
@@ -155,6 +152,6 @@ src_install() {
emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
- cd "${D}"${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid}
unzip "${S}"/mozilla/dist/bin/*.xpi
}