summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-04-04 09:26:21 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-04-04 09:26:21 +0000
commit9ef137ec1080d55a133c6d1f37d8abade4411cdc (patch)
treec97f74c71f46da6cd040f01229946ce6fae47fd2 /x11-plugins/cputnik/cputnik-0.2.0.ebuild
parentRemoved mail-client/ciphire-mail (diff)
downloadgentoo-2-9ef137ec1080d55a133c6d1f37d8abade4411cdc.tar.gz
gentoo-2-9ef137ec1080d55a133c6d1f37d8abade4411cdc.tar.bz2
gentoo-2-9ef137ec1080d55a133c6d1f37d8abade4411cdc.zip
Version bump + QA fixes. Closes bug #207725.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/cputnik/cputnik-0.2.0.ebuild')
-rw-r--r--x11-plugins/cputnik/cputnik-0.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/cputnik/cputnik-0.2.0.ebuild b/x11-plugins/cputnik/cputnik-0.2.0.ebuild
new file mode 100644
index 000000000000..ef58089ed9c1
--- /dev/null
+++ b/x11-plugins/cputnik/cputnik-0.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/cputnik/cputnik-0.2.0.ebuild,v 1.1 2008/04/04 09:26:21 s4t4n Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="cputnik is a simple cpu monitor dockapp."
+HOMEPAGE="http://www.dockapps.org/file.php/id/273"
+SRC_URI="http://www.dockapps.org/download.php/id/576/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Compilation failed"
+}
+
+src_install() {
+ dobin cputnik
+ dodoc ../{AUTHORS,NEWS,README}
+}