summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-03 17:01:59 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2009-04-03 17:01:59 +0000
commit447d048fbf77701a9f4afef3600a09c26eee4a5c (patch)
treebe19647ea11edc5b6ca6f9a70b793c1e94503d2b /x11-plugins/compiz-plugins-main
parentAdded missing patch. (diff)
downloadgentoo-2-447d048fbf77701a9f4afef3600a09c26eee4a5c.tar.gz
gentoo-2-447d048fbf77701a9f4afef3600a09c26eee4a5c.tar.bz2
gentoo-2-447d048fbf77701a9f4afef3600a09c26eee4a5c.zip
Added another patch.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/compiz-plugins-main')
-rw-r--r--x11-plugins/compiz-plugins-main/ChangeLog7
-rw-r--r--x11-plugins/compiz-plugins-main/files/compiz-plugins-main-0.8.2-xdamage-race.patch30
-rw-r--r--x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch22
3 files changed, 58 insertions, 1 deletions
diff --git a/x11-plugins/compiz-plugins-main/ChangeLog b/x11-plugins/compiz-plugins-main/ChangeLog
index c896ba39a121..5eaecc02ed62 100644
--- a/x11-plugins/compiz-plugins-main/ChangeLog
+++ b/x11-plugins/compiz-plugins-main/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/compiz-plugins-main
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-main/ChangeLog,v 1.2 2009/04/03 16:57:43 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-main/ChangeLog,v 1.3 2009/04/03 17:01:59 jmbsvicetto Exp $
+
+ 03 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +files/compiz-plugins-main-0.8.2-xdamage-race.patch,
+ +files/compiz-plugins-main-no-gconf.patch:
+ Added another patch.
03 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+files/compiz-plugins-main-0.8.2-xdamage-race.patch:
diff --git a/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-0.8.2-xdamage-race.patch b/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-0.8.2-xdamage-race.patch
new file mode 100644
index 000000000000..ee167b8319c9
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-0.8.2-xdamage-race.patch
@@ -0,0 +1,30 @@
+diff --git a/src/workarounds/workarounds.c b/src/workarounds/workarounds.c
+index 5e0c221..f987fa0 100644
+--- a/src/workarounds/workarounds.c
++++ b/src/workarounds/workarounds.c
+@@ -198,6 +198,9 @@ workaroundsPaintScreen (CompScreen *s,
+
+ currentScreen = s;
+
++ if (workaroundsGetForceGlxSync (s->display))
++ glXWaitX ();
++
+ UNWRAP (ws, s, paintScreen);
+ (*s->paintScreen) (s, outputs, numOutputs, mask);
+ WRAP (ws, s, paintScreen, workaroundsPaintScreen);
+diff --git a/metadata/workarounds.xml.in b/metadata/workarounds.xml.in
+index 5eb072d..1648e88 100644
+--- a/metadata/workarounds.xml.in
++++ b/metadata/workarounds.xml.in
+@@ -53,6 +53,11 @@
+ <_long>Fix for broken GLX_MESA_copy_sub_buffer on XGL in fglrx.</_long>
+ <default>false</default>
+ </option>
++ <option type="bool" name="force_glx_sync">
++ <_short>Force synchronization between X and GLX</_short>
++ <_long>Force synchronization between X and GLX, which may help for window parts not redrawing correctly when using Nvidia drivers, but also may decrease performance.</_long>
++ <default>false</default>
++ </option>
+ <subgroup>
+ <_short>Window stickyness</_short>
+ <option type="bool" name="sticky_alldesktops">
diff --git a/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch b/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch
new file mode 100644
index 000000000000..63222a5f1ce6
--- /dev/null
+++ b/x11-plugins/compiz-plugins-main/files/compiz-plugins-main-no-gconf.patch
@@ -0,0 +1,22 @@
+ configure.ac | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 297a8cf..290e92b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -171,11 +171,10 @@
+ if test x"$use_schemas" = x"yes"; then
+ fi
+ xsltdir=`$PKG_CONFIG --variable=xsltdir compiz-gconf`
+ AC_SUBST(xsltdir)
++else
++ AM_CONDITIONAL(GCONF_SCHEMAS_INSTALL, test "x$use_gconf" = "xyes")
+ fi
+
+-AM_GCONF_SOURCE_2
+-
+-
+ AM_CONDITIONAL(USE_SCHEMAS, test "x$use_schemas" = "xyes")
+ if test "$use_schemas" = yes; then
+ AC_DEFINE(USE_SCHEMAS, 1, [Build gconf schemas])