summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2012-05-28 21:58:14 +0000
committerTristan Heaven <tristan@gentoo.org>2012-05-28 21:58:14 +0000
commitfea465e60ac362c5a926bd7a01f88ba4a50fd360 (patch)
tree098b367374c2e515b9541d01f0a95926d1321295 /x11-misc
parentmedia-gfx/gimp: Resolve linguas code duplication for bug #418053 (diff)
downloadgentoo-2-fea465e60ac362c5a926bd7a01f88ba4a50fd360.tar.gz
gentoo-2-fea465e60ac362c5a926bd7a01f88ba4a50fd360.tar.bz2
gentoo-2-fea465e60ac362c5a926bd7a01f88ba4a50fd360.zip
Version bump, bug #395199
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/revelation/ChangeLog7
-rw-r--r--x11-misc/revelation/revelation-0.4.13.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-misc/revelation/ChangeLog b/x11-misc/revelation/ChangeLog
index 0e7ec123dcd6..2a9fa3b63e50 100644
--- a/x11-misc/revelation/ChangeLog
+++ b/x11-misc/revelation/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/revelation
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.22 2012/05/22 16:46:15 tristan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.23 2012/05/28 21:58:14 tristan Exp $
+
+*revelation-0.4.13 (28 May 2012)
+
+ 28 May 2012; Tristan Heaven <tristan@gentoo.org> +revelation-0.4.13.ebuild:
+ Version bump, bug #395199
22 May 2012; Tristan Heaven <tristan@gentoo.org> revelation-0.4.11-r2.ebuild:
Update python eclass usage and require python-2, bug #321879 #412799
diff --git a/x11-misc/revelation/revelation-0.4.13.ebuild b/x11-misc/revelation/revelation-0.4.13.ebuild
new file mode 100644
index 000000000000..3f99ea78f62a
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.13.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.13.ebuild,v 1.1 2012/05/28 21:58:14 tristan Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+GCONF_DEBUG="no"
+
+inherit python gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://revelation.olasagasti.info/"
+SRC_URI="https://bitbucket.org/erikg/revelation/downloads/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="applet"
+RESTRICT="test"
+
+RDEPEND="dev-python/pygtk
+ dev-python/pycrypto
+ dev-python/gconf-python
+ dev-python/gnome-vfs-python
+ dev-python/libbonobo-python
+ dev-python/libgnome-python
+ sys-libs/cracklib[python]
+ applet? ( dev-python/gnome-applets-python )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ gnome2_src_prepare
+ echo -n > py-compile
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-desktop-update \
+ --disable-mime-update \
+ $(use_with applet)
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ gnome2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup ${PN}
+}