summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-10 23:55:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-10 23:55:43 +0000
commitf7d57595c02a9c9f671b18559dd1097c7609aefc (patch)
tree71901e88810fb978fbbdb28cf4b808c0aef1bf6b /x11-misc
parentVersion bump to KDE 4.0.2. (diff)
downloadgentoo-2-f7d57595c02a9c9f671b18559dd1097c7609aefc.tar.gz
gentoo-2-f7d57595c02a9c9f671b18559dd1097c7609aefc.tar.bz2
gentoo-2-f7d57595c02a9c9f671b18559dd1097c7609aefc.zip
bump to 0.11.5
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/alacarte/ChangeLog8
-rw-r--r--x11-misc/alacarte/alacarte-0.11.5.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/x11-misc/alacarte/ChangeLog b/x11-misc/alacarte/ChangeLog
index d403b554d2c9..4c86ce285855 100644
--- a/x11-misc/alacarte/ChangeLog
+++ b/x11-misc/alacarte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/alacarte
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.45 2008/02/18 00:23:09 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.46 2008/03/10 23:55:43 eva Exp $
+
+*alacarte-0.11.5 (10 Mar 2008)
+
+ 10 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +alacarte-0.11.5.ebuild:
+ bump to 0.11.5, updated translation and fixed one crash
*alacarte-0.11.4 (18 Feb 2008)
diff --git a/x11-misc/alacarte/alacarte-0.11.5.ebuild b/x11-misc/alacarte/alacarte-0.11.5.ebuild
new file mode 100644
index 000000000000..ff88d2773766
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-0.11.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.11.5.ebuild,v 1.1 2008/03/10 23:55:43 eva Exp $
+
+inherit gnome2 python eutils autotools
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="http://www.realistanew.com/projects/alacarte"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+SLOT=0
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-python/pygtk-2.8
+ >=gnome-base/gnome-menus-2.18
+ >=dev-python/gnome-python-2.18"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if ! built_with_use gnome-base/gnome-menus python ; then
+ eerror "You must emerge gnome-base/gnome-menus with the python USE flag"
+ die "alacarte needs python support in gnome-base/gnome-menus"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}"/${PN}-0.11.3-python-2.5.patch
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ eautoreconf
+ intltoolize --force
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/Alacarte
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup
+}