summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-05 01:34:12 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-05 01:34:12 +0000
commited537b527f906f60005b8ae311c84440cee8f94a (patch)
tree38d2b6f164d49d978be0b15eb44268b05a1f545b /x11-misc
parentstable amd64/sparc, bug 272352 (diff)
downloadgentoo-2-ed537b527f906f60005b8ae311c84440cee8f94a.tar.gz
gentoo-2-ed537b527f906f60005b8ae311c84440cee8f94a.tar.bz2
gentoo-2-ed537b527f906f60005b8ae311c84440cee8f94a.zip
Version bump. Fix desktop file to not break Gnome and possibly other environments, bug 272318.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pcmanfm/ChangeLog11
-rw-r--r--x11-misc/pcmanfm/files/pcmanfm-find.desktop.patch10
-rw-r--r--x11-misc/pcmanfm/pcmanfm-0.5.1.ebuild63
3 files changed, 82 insertions, 2 deletions
diff --git a/x11-misc/pcmanfm/ChangeLog b/x11-misc/pcmanfm/ChangeLog
index a15ba17add8a..3b1e60a3be3c 100644
--- a/x11-misc/pcmanfm/ChangeLog
+++ b/x11-misc/pcmanfm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/pcmanfm
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/ChangeLog,v 1.2 2008/09/04 11:36:42 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/ChangeLog,v 1.3 2009/06/05 01:34:11 yngwin Exp $
+
+*pcmanfm-0.5.1 (05 Jun 2009)
+
+ 05 Jun 2009; Ben de Groot <yngwin@gentoo.org> +pcmanfm-0.5.1.ebuild,
+ +files/pcmanfm-find.desktop.patch:
+ Version bump. Fix desktop file to not break Gnome and possibly other
+ environments, bug 272318.
04 Sep 2008; Ben de Groot <yngwin@gentoo.org> metadata.xml:
Reassigning maintainership to lxde team as a whole
diff --git a/x11-misc/pcmanfm/files/pcmanfm-find.desktop.patch b/x11-misc/pcmanfm/files/pcmanfm-find.desktop.patch
new file mode 100644
index 000000000000..86aee0fdc0e4
--- /dev/null
+++ b/x11-misc/pcmanfm/files/pcmanfm-find.desktop.patch
@@ -0,0 +1,10 @@
+--- pcmanfm-0.5.1.orig/data/pcmanfm-find.desktop.in 2009-06-05 03:18:37.000000000 +0200
++++ pcmanfm-0.5.1/data/pcmanfm-find.desktop.in 2009-06-05 03:18:50.000000000 +0200
+@@ -12,7 +12,6 @@
+ StartupNotify=true
+ Type=Application
+ Terminal=false
+-MimeType=x-directory/normal;inode/directory;
+ Comment=Search for files and folders in disks
+ Comment[ru]=Поиск Файлов или Папок на дисках
+ Comment[zh_TW]=在磁碟中尋找檔案或資料夾
diff --git a/x11-misc/pcmanfm/pcmanfm-0.5.1.ebuild b/x11-misc/pcmanfm/pcmanfm-0.5.1.ebuild
new file mode 100644
index 000000000000..9471c4a93ab5
--- /dev/null
+++ b/x11-misc/pcmanfm/pcmanfm-0.5.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/pcmanfm-0.5.1.ebuild,v 1.1 2009/06/05 01:34:11 yngwin Exp $
+
+EAPI="2"
+inherit eutils fdo-mime
+
+DESCRIPTION="Extremely fast and lightweight tabbed file manager"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+
+RDEPEND="virtual/fam
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-misc/shared-mime-info
+ x11-themes/gnome-icon-theme
+ x11-libs/startup-notification
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ # Don't break Gnome & possibly other environments, bug 272318
+ epatch "${FILESDIR}"/pcmanfm-find.desktop.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable hal)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ if has_version app-admin/fam ; then
+ elog "You are using fam as your file alteration monitor,"
+ elog "so you must have famd started before running pcmanfm."
+ elog
+ elog "To add famd to the default runlevel and start it, run:"
+ elog
+ elog "# rc-update add famd default"
+ elog "# /etc/init.d/famd start"
+ elog
+ elog "It is recommended you use gamin instead of fam."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}