summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-01-09 13:04:37 +0000
committerJeroen Roovers <jer@gentoo.org>2012-01-09 13:04:37 +0000
commite845093d32bf889d8fa959ffbc9dbd50829149c0 (patch)
tree3b8d81d5105856e5e5698b610e5848ba6370a03c /x11-misc
parentFix security flaw in EDE, bug 398227. Unchanged revbump for emacs-23 live (diff)
downloadgentoo-2-e845093d32bf889d8fa959ffbc9dbd50829149c0.tar.gz
gentoo-2-e845093d32bf889d8fa959ffbc9dbd50829149c0.tar.bz2
gentoo-2-e845093d32bf889d8fa959ffbc9dbd50829149c0.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dmenu/ChangeLog7
-rw-r--r--x11-misc/dmenu/dmenu-4.5.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index efc80b0b47a4..79e39951c022 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.77 2012/01/04 20:23:29 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.78 2012/01/09 13:04:37 jer Exp $
+
+*dmenu-4.5 (09 Jan 2012)
+
+ 09 Jan 2012; Jeroen Roovers <jer@gentoo.org> +dmenu-4.5.ebuild:
+ Version bump.
04 Jan 2012; Brent Baude <ranger@gentoo.org> dmenu-4.4.1.ebuild:
Marking dmenu-4.4.1 ppc for bug 389219
diff --git a/x11-misc/dmenu/dmenu-4.5.ebuild b/x11-misc/dmenu/dmenu-4.5.ebuild
new file mode 100644
index 000000000000..789e7a39ea57
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-4.5.ebuild,v 1.1 2012/01/09 13:04:37 jer Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -ansi -pedantic -Wall -Os/CFLAGS += -ansi -pedantic -Wall/" \
+ -e "s/LDFLAGS = -s/LDFLAGS +=/" \
+ -e "s/XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC=$(tc-getCC)
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS=""
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}