summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-07-21 21:03:55 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-07-21 21:03:55 +0000
commite240ad44ec144ba205e2dc9862715c33bad867ed (patch)
treeaaee9e5e1f1d5a5e971e6cb9a61885f14bf8561b /x11-misc
parentLinux patch 3.9.11; security fixes for CVE-2013-4125 and CVE-2013-4129, see b... (diff)
downloadgentoo-2-e240ad44ec144ba205e2dc9862715c33bad867ed.tar.gz
gentoo-2-e240ad44ec144ba205e2dc9862715c33bad867ed.tar.bz2
gentoo-2-e240ad44ec144ba205e2dc9862715c33bad867ed.zip
Version bump.
(Portage version: 2.2.0_alpha182_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xmobar/ChangeLog8
-rw-r--r--x11-misc/xmobar/metadata.xml5
-rw-r--r--x11-misc/xmobar/xmobar-0.18.ebuild75
3 files changed, 84 insertions, 4 deletions
diff --git a/x11-misc/xmobar/ChangeLog b/x11-misc/xmobar/ChangeLog
index d9aca24cd86c..1c26028b73a4 100644
--- a/x11-misc/xmobar/ChangeLog
+++ b/x11-misc/xmobar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xmobar
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.22 2013/02/21 20:58:50 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/ChangeLog,v 1.23 2013/07/21 21:03:55 slyfox Exp $
+
+*xmobar-0.18 (21 Jul 2013)
+
+ 21 Jul 2013; Sergei Trofimovich <slyfox@gentoo.org> +xmobar-0.18.ebuild,
+ metadata.xml:
+ Version bump.
*xmobar-0.16-r1 (21 Feb 2013)
diff --git a/x11-misc/xmobar/metadata.xml b/x11-misc/xmobar/metadata.xml
index 41afa1d40fb2..30ee2d2b729c 100644
--- a/x11-misc/xmobar/metadata.xml
+++ b/x11-misc/xmobar/metadata.xml
@@ -8,10 +8,9 @@
<use>
<flag name='mail'>Support the mail plugin. Pulls dependency dev-haskell/hinotify.</flag>
<flag name='mpd'>Support mpd plugin</flag>
- <flag name='timezone'>Enables localized date support</flag>
<flag name='mpris'>Enables MPRIS v1, v2 support</flag>
-
-
+ <flag name='threaded'>Use threaded GHC runtime</flag>
+ <flag name='timezone'>Enables localized date support</flag>
</use>
<longdescription>
Xmobar is a minimalistic text based status bar.
diff --git a/x11-misc/xmobar/xmobar-0.18.ebuild b/x11-misc/xmobar/xmobar-0.18.ebuild
new file mode 100644
index 000000000000..ca59b66958b5
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.18.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.18.ebuild,v 1.1 2013/07/21 21:03:55 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://projects.haskell.org/xmobar/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#hackport: ignore-use all_extansions
+#hackport: rename-use with_alsa alsa
+#hackport: rename-use with_datezone timezone
+#hackport: rename-use with_threaded threaded
+#hackport: rename-use with_dbus dbus
+IUSE="alsa timezone threaded dbus inotify wifi mpd mpris mail xft"
+
+# xft? ( net-wireless/iw )
+RDEPEND="x11-libs/libXrandr
+ wifi? ( net-wireless/wireless-tools )
+ "
+
+DEPEND="${RDEPEND}
+ >=dev-lang/ghc-6.12.1
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/mtl-2.0
+ <dev-haskell/mtl-2.2
+ =dev-haskell/parsec-3.1*
+ dev-haskell/regex-compat
+ >=dev-haskell/stm-2.3
+ <dev-haskell/stm-2.5
+ >=dev-haskell/x11-1.6.1
+ alsa? ( =dev-haskell/alsa-mixer-0.1*
+ =dev-haskell/alsa-core-0.5*
+ )
+ dbus? ( >=dev-haskell/dbus-0.10 )
+ mail? ( =dev-haskell/hinotify-0.3* )
+ mpd? ( =dev-haskell/libmpd-0.8* )
+ mpris? ( >=dev-haskell/dbus-0.10 )
+ timezone? ( =dev-haskell/timezone-olson-0.1*
+ =dev-haskell/timezone-series-0.1*
+ )
+ xft? ( <dev-haskell/x11-xft-0.4
+ >=dev-haskell/x11-xft-0.2
+ =dev-haskell/utf8-string-0.3*
+ )"
+RDEPEND+="mpd? ( media-sound/mpd )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flags=with_utf8 \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag timezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ $(cabal_flag inotify with_inotify) \
+ $(cabal_flag wifi with_iwlib) \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ $(cabal_flag threaded with_threaded) \
+ $(cabal_flag xft with_xft)
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc samples/xmobar.config readme.md news.md
+}