summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-05-10 18:48:44 +0000
committerBryan Stine <battousai@gentoo.org>2004-05-10 18:48:44 +0000
commite08b4684bd551177113e024f2f3feb8713502dbf (patch)
tree36a99a53a689d4b18c84dcbda7e668f64ea3e00f /x11-misc
parentprune old ebuilds (Manifest recommit) (diff)
downloadgentoo-2-e08b4684bd551177113e024f2f3feb8713502dbf.tar.gz
gentoo-2-e08b4684bd551177113e024f2f3feb8713502dbf.tar.bz2
gentoo-2-e08b4684bd551177113e024f2f3feb8713502dbf.zip
Version bump, fixes bug 49862.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/linuxwacom/ChangeLog7
-rw-r--r--x11-misc/linuxwacom/files/digest-linuxwacom-0.6.21
-rw-r--r--x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/x11-misc/linuxwacom/ChangeLog b/x11-misc/linuxwacom/ChangeLog
index 771c7f722933..a60eb1db433e 100644
--- a/x11-misc/linuxwacom/ChangeLog
+++ b/x11-misc/linuxwacom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/linuxwacom
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.3 2004/04/07 21:02:01 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/ChangeLog,v 1.4 2004/05/10 18:48:44 battousai Exp $
+
+*linuxwacom-0.6.2 (10 May 2004)
+
+ 10 May 2004; Bryan Stine <battousai@gentoo.org>; linuxwacom-0.6.2.ebuild:
+ Version bump, fixes bug 49862.
07 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>;
linuxwacom-0.6.0.ebuild:
diff --git a/x11-misc/linuxwacom/files/digest-linuxwacom-0.6.2 b/x11-misc/linuxwacom/files/digest-linuxwacom-0.6.2
new file mode 100644
index 000000000000..7981a35ec1eb
--- /dev/null
+++ b/x11-misc/linuxwacom/files/digest-linuxwacom-0.6.2
@@ -0,0 +1 @@
+MD5 c178bd5b2c634b3d04ae63034c3f8745 linuxwacom-0.6.2.tar.bz2 443100
diff --git a/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild b/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
new file mode 100644
index 000000000000..342bea0a0022
--- /dev/null
+++ b/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/linuxwacom/linuxwacom-0.6.2.ebuild,v 1.1 2004/05/10 18:48:44 battousai Exp $
+
+DESCRIPTION="Input driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="|| ( >=x11-base/xfree-4.3.0-r6 x11-base/xorg-x11 )"
+
+pkg_setup() {
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xfree-[0-9]*/USE`" ]
+ then
+ eerror "This package builds against the XFree86 SDK, and therefore requires"
+ eerror "that you have emerged xfree with the sdk USE flag enabled."
+ die "Please remerge xfree with the sdk USE flag enabled."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Simple fixes to configure to check the actual location of the XFree86 SDK
+ cd ${S}
+ sed -i -e "s:XF86SUBDIR=.*:XF86SUBDIR=include:" configure
+ sed -i -e "s:XF86V3SUBDIR=.*:XF86V3SUBDIR=include:" configure
+}
+
+src_compile() {
+ myconf="--enable-wacomdrv --enable-wacomdrvv3 --with-xf86=/usr/X11R6/lib/Server \
+ --with-xf86v3=/usr/X11R6/lib/Server"
+ econf ${myconf} || die "configure failed."
+
+ # Makefile fix for build against SDK
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -i -e "s:XF86_DIR = .*:XF86_DIR = /usr/X11R6/lib/Server:" Makefile
+ sed -i -e "s:XF86_V3_DIR = .*:XF86_V3_DIR = /usr/X11R6/lib/Server:" Makefile
+ sed -i -e "s:/include/extensions:/include:g" Makefile
+ cd ${S}
+
+ emake || die "build failed."
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Install failed."
+}