summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-01 04:38:36 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-01 04:38:36 +0000
commitd4b511fcfc5cf0c009fa7807d730935a5236b52e (patch)
tree848d449e7219f3007085f3bbc67eef0b170f1187 /x11-misc
parent- Fix build error w/ USE="tetex". (bug #102174, Jochen Schlick) (diff)
downloadgentoo-2-d4b511fcfc5cf0c009fa7807d730935a5236b52e.tar.gz
gentoo-2-d4b511fcfc5cf0c009fa7807d730935a5236b52e.tar.bz2
gentoo-2-d4b511fcfc5cf0c009fa7807d730935a5236b52e.zip
Clean up. Had false configure switches, missing depends, virtual/x11..
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xplanet/ChangeLog5
-rw-r--r--x11-misc/xplanet/xplanet-1.2.0.ebuild63
2 files changed, 27 insertions, 41 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 50227810238b..275216ef9c40 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/xplanet
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.60 2007/02/22 00:07:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.61 2007/07/01 04:38:36 drac Exp $
+
+ 01 Jul 2007; Samuli Suominen <drac@gentoo.org> xplanet-1.2.0.ebuild:
+ Clean up.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-misc/xplanet/xplanet-1.2.0.ebuild b/x11-misc/xplanet/xplanet-1.2.0.ebuild
index ef101e7e2ca8..8022d5473ade 100644
--- a/x11-misc/xplanet/xplanet-1.2.0.ebuild
+++ b/x11-misc/xplanet/xplanet-1.2.0.ebuild
@@ -1,52 +1,37 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.2.0.ebuild,v 1.11 2006/05/06 16:23:02 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.2.0.ebuild,v 1.12 2007/07/01 04:38:36 drac Exp $
-DESCRIPTION="A program to render images of the earth into the X root window"
+DESCRIPTION="a program to render images of the earth into the X root window"
+HOMEPAGE="http://xplanet.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://xplanet.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE="gif jpeg X opengl truetype tiff png"
+IUSE="gif jpeg X truetype tiff png"
-RDEPEND="X? ( || ( (
- x11-libs/libX11
- x11-libs/libXScrnSaver
- x11-libs/libXt
- x11-libs/libXext )
- virtual/x11 ) )
- opengl? ( virtual/opengl
- virtual/glut )
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXt
+ x11-libs/libXext )
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
tiff? ( media-libs/tiff )
- png? ( media-libs/libpng )
- truetype? ( =media-libs/freetype-2* )"
+ png? ( media-libs/libpng
+ media-libs/netpbm )
+ truetype? ( =media-libs/freetype-2*
+ x11-libs/pango )"
DEPEND="${RDEPEND}
- X? ( || ( (
- x11-proto/xproto
- x11-proto/scrnsaverproto )
- virtual/x11 ) )"
-
-src_unpack() {
- unpack ${A}
- # fix GCC3.2 include re-ordering bug.
- cd ${S}
- sed -i 's,-I$prefix/include,,' configure
-}
+ X? ( x11-proto/xproto
+ x11-proto/scrnsaverproto )"
src_compile() {
local myconf
use X \
- && myconf="${myconf} --with-x" \
- || myconf="${myconf} --with-x=no"
-
- use opengl \
- && myconf="${myconf} --with-gl --with-glut --with-animation" \
- || myconf="${myconf} --with-gl=no --with-glut=no --with-animation=no"
+ && myconf="${myconf} --with-x --with-xscreensaver" \
+ || myconf="${myconf} --with-x=no --with-xscreensaver=no"
use gif \
&& myconf="${myconf} --with-gif" \
@@ -65,16 +50,14 @@ src_compile() {
|| myconf="${myconf} --with-png=no --with-pnm=no"
use truetype \
- && myconf="${myconf} --with-freetype" \
- || myconf="${myconf} --with-freetype=no"
-
- econf ${myconf} || die
+ && myconf="${myconf} --with-freetype --with-pango" \
+ || myconf="${myconf} --with-freetype=no --with-pango=no"
- # xplanet doesn't like to build parallel
- make || die
+ econf --with-cspice=no ${myconf}
+ emake -j1 || die "emake failed."
}
src_install () {
- einstall || die "einstall failed"
- dodoc AUTHORS README NEWS ChangeLog TODO
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
}