summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-10-22 14:56:20 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-10-22 14:56:20 +0000
commitd22bed637f42631a1dd5013e57c1f108fdbf5683 (patch)
treeef1f2a9f62315437e7457e8c9d1bb3dd2554c05d /x11-misc
parentStable for HPPA (bug #488412). (diff)
downloadgentoo-2-d22bed637f42631a1dd5013e57c1f108fdbf5683.tar.gz
gentoo-2-d22bed637f42631a1dd5013e57c1f108fdbf5683.tar.bz2
gentoo-2-d22bed637f42631a1dd5013e57c1f108fdbf5683.zip
backported security fix for bug 487688
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slim/ChangeLog8
-rw-r--r--x11-misc/slim/files/slim-1.3.5-glibc217-crypt.patch11
-rw-r--r--x11-misc/slim/slim-1.3.5-r4.ebuild113
3 files changed, 131 insertions, 1 deletions
diff --git a/x11-misc/slim/ChangeLog b/x11-misc/slim/ChangeLog
index 38ed17e74e67..c9567405da4e 100644
--- a/x11-misc/slim/ChangeLog
+++ b/x11-misc/slim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/slim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.119 2013/10/17 18:39:31 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/ChangeLog,v 1.120 2013/10/22 14:56:20 axs Exp $
+
+*slim-1.3.5-r4 (22 Oct 2013)
+
+ 22 Oct 2013; Ian Stakenvicius <axs@gentoo.org>
+ +files/slim-1.3.5-glibc217-crypt.patch, +slim-1.3.5-r4.ebuild:
+ backported security fix for bug 487688
*slim-1.3.6-r1 (17 Oct 2013)
diff --git a/x11-misc/slim/files/slim-1.3.5-glibc217-crypt.patch b/x11-misc/slim/files/slim-1.3.5-glibc217-crypt.patch
new file mode 100644
index 000000000000..71807f0588e4
--- /dev/null
+++ b/x11-misc/slim/files/slim-1.3.5-glibc217-crypt.patch
@@ -0,0 +1,11 @@
+--- app.cpp 2013-10-22 10:45:54.041120246 -0400
++++ app.cpp.new 2013-10-22 10:46:58.864122061 -0400
+@@ -486,7 +486,7 @@
+ return true;
+
+ encrypted = crypt(LoginPanel->GetPasswd().c_str(), correct);
+- return ((strcmp(encrypted, correct) == 0) ? true : false);
++ return ((encrypted && strcmp(encrypted, correct) == 0) ? true : false);
+ }
+ #endif
+
diff --git a/x11-misc/slim/slim-1.3.5-r4.ebuild b/x11-misc/slim/slim-1.3.5-r4.ebuild
new file mode 100644
index 000000000000..f5c567ea8161
--- /dev/null
+++ b/x11-misc/slim/slim-1.3.5-r4.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slim/slim-1.3.5-r4.ebuild,v 1.1 2013/10/22 14:56:20 axs Exp $
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.8"
+inherit cmake-utils pam eutils systemd versionator
+
+DESCRIPTION="Simple Login Manager"
+HOMEPAGE="http://slim.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="branding pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXft
+ media-libs/libpng:0=
+ virtual/jpeg
+ x11-apps/sessreg
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+PDEPEND="branding? ( >=x11-themes/slim-themes-1.2.3a-r3 )"
+
+src_prepare() {
+ # Our Gentoo-specific config changes
+ epatch "${FILESDIR}"/${PN}-1.3.4-config.diff
+ epatch "${FILESDIR}"/${P}-arm.patch
+ epatch "${FILESDIR}"/${P}-systemd-service.patch
+ epatch "${FILESDIR}"/${P}-honour-cflags.patch
+ epatch "${FILESDIR}"/${P}-disable-ck-for-systemd.patch
+ epatch "${FILESDIR}"/${P}-glibc217-crypt.patch
+
+ if use elibc_FreeBSD; then
+ sed -i -e 's/"-DHAVE_SHADOW"/"-DNEEDS_BASENAME"/' CMakeLists.txt \
+ || die
+ fi
+
+ if use branding; then
+ sed -i -e 's/ default/ slim-gentoo-simple/' slim.conf || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use pam USE_PAM)
+ $(cmake-utils_use consolekit USE_CONSOLEKIT)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use pam ; then
+ pamd_mimic system-local-login slim auth account session
+ fi
+
+ insinto /usr/share/slim
+ newins "${FILESDIR}/Xsession-r3" Xsession
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/slim.logrotate" slim
+
+ dodoc xinitrc.sample ChangeLog README TODO THEMES
+}
+
+pkg_postinst() {
+ # note, $REPLACING_VERSIONS will always contain 0 or 1 PV's for slim
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "The configuration file is located at /etc/slim.conf."
+ elog
+ elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
+ elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
+ fi
+ if ! version_is_at_least "1.3.2-r7" "${REPLACING_VERSIONS:-1.0}" ; then
+ elog
+ elog "By default, ${PN} is set up to do proper X session selection, including ~/.xsession"
+ elog "support, as well as selection between sessions available in"
+ elog "/etc/X11/Sessions/ at login by pressing [F1]."
+ elog
+ elog "The XSESSION environment variable is still supported as a default"
+ elog "if no session has been specified by the user."
+ elog
+ elog "If you want to use .xinitrc in the user's home directory for session"
+ elog "management instead, see README and xinitrc.sample in"
+ elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
+ elog "accordingly."
+ elog
+ ewarn "Please note that slim supports consolekit directly. Please do not use any "
+ ewarn "old work-arounds (including calls to 'ck-launch-session' in xinitrc scripts)"
+ ewarn "and enable USE=\"consolekit\" instead."
+ ewarn
+ fi
+ if ! use pam; then
+ elog "You have merged ${PN} without USE=\"pam\", this will cause ${PN} to fall back to"
+ elog "the console when restarting your window manager. If this is not desired, then"
+ elog "please remerge ${PN} with USE=\"pam\""
+ elog
+ fi
+}