summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-06-29 16:09:40 +0000
committerChristoph Mende <angelos@gentoo.org>2012-06-29 16:09:40 +0000
commitc51b3b2882614d06afd1d1cacea02a41622f9cfb (patch)
treeb92e63e80330f9d99d57e9ed41a5dfb4a40ad928 /x11-misc
parentOh, seems we already had this one. (diff)
downloadgentoo-2-c51b3b2882614d06afd1d1cacea02a41622f9cfb.tar.gz
gentoo-2-c51b3b2882614d06afd1d1cacea02a41622f9cfb.tar.bz2
gentoo-2-c51b3b2882614d06afd1d1cacea02a41622f9cfb.zip
Version bump (bug #423903)
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rodent/ChangeLog8
-rw-r--r--x11-misc/rodent/metadata.xml4
-rw-r--r--x11-misc/rodent/rodent-4.8.0.ebuild40
3 files changed, 49 insertions, 3 deletions
diff --git a/x11-misc/rodent/ChangeLog b/x11-misc/rodent/ChangeLog
index 4fecfad330a7..a8b6d8c3bab5 100644
--- a/x11-misc/rodent/ChangeLog
+++ b/x11-misc/rodent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/rodent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/ChangeLog,v 1.7 2012/05/05 04:53:43 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/ChangeLog,v 1.8 2012/06/29 16:09:40 angelos Exp $
+
+*rodent-4.8.0 (29 Jun 2012)
+
+ 29 Jun 2012; <christoph@gentoo.org> +rodent-4.8.0.ebuild, metadata.xml:
+ Version bump (bug #423903)
05 May 2012; Jeff Horelick <jdhore@gentoo.org> rodent-4.6.4.ebuild,
rodent-4.7.4.ebuild:
@@ -34,4 +39,3 @@
02 Apr 2011; Christoph Mende <angelos@gentoo.org> +rodent-4.6.2.ebuild,
+files/rodent-4.6.2-libs.patch, +metadata.xml:
Initial import
-
diff --git a/x11-misc/rodent/metadata.xml b/x11-misc/rodent/metadata.xml
index 237f5f649f23..7b818e716765 100644
--- a/x11-misc/rodent/metadata.xml
+++ b/x11-misc/rodent/metadata.xml
@@ -3,5 +3,7 @@
<pkgmetadata>
<herd>xfce</herd>
<longdescription lang="en">Rodent is fast, small and powerful file manager for the GNU operating system (but it also works in BSD). Rodent is *not* a filemanager for dummies. Emphasis is on ease of use for the advanced user, not the computer illiterate.</longdescription>
+<use>
+ <flag name="experimental">Build experimental plugins (obexfs, curlftpfs, ecryptfs, cifs and samba)</flag>
+</use>
</pkgmetadata>
-
diff --git a/x11-misc/rodent/rodent-4.8.0.ebuild b/x11-misc/rodent/rodent-4.8.0.ebuild
new file mode 100644
index 000000000000..7fe0a46779a7
--- /dev/null
+++ b/x11-misc/rodent/rodent-4.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/rodent-4.8.0.ebuild,v 1.1 2012/06/29 16:09:40 angelos Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A fast, small and powerful file manager and graphical shell"
+HOMEPAGE="http://rodent.xffm.org/"
+SRC_URI="mirror://sourceforge/xffm/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="x11-libs/libX11
+ x11-libs/libSM
+ dev-libs/libxml2
+ >=dev-libs/glib-2.24
+ x11-libs/gtk+:3
+ >=x11-libs/cairo-1.8.10
+ >=gnome-base/librsvg-2.26
+ >=dev-libs/libzip-0.9
+ sys-apps/file"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=( $(use_with experimental) )
+ DOCS=( ChangeLog README TODO )
+}
+
+src_install() {
+ # Build/share/Makefile.am:docdir = $(datadir)/doc/@PLUGIN_DIR@
+ xfconf_src_install docdir=/usr/share/doc/${PF}
+}