summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-18 17:18:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-18 17:18:36 +0000
commitaee3f7eb2e5334ed1d74627affa437e72bb979ba (patch)
tree2bbb236bb956aa18a9a8529d0459acc85c49f742 /x11-misc
parentVersion bump (diff)
downloadgentoo-2-aee3f7eb2e5334ed1d74627affa437e72bb979ba.tar.gz
gentoo-2-aee3f7eb2e5334ed1d74627affa437e72bb979ba.tar.bz2
gentoo-2-aee3f7eb2e5334ed1d74627affa437e72bb979ba.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pcmanfm/ChangeLog7
-rw-r--r--x11-misc/pcmanfm/pcmanfm-0.9.3.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/pcmanfm/ChangeLog b/x11-misc/pcmanfm/ChangeLog
index 81d60700eeb4..d218cbed9364 100644
--- a/x11-misc/pcmanfm/ChangeLog
+++ b/x11-misc/pcmanfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/pcmanfm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/ChangeLog,v 1.18 2010/03/13 16:31:58 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/ChangeLog,v 1.19 2010/03/18 17:18:36 hwoarang Exp $
+
+*pcmanfm-0.9.3 (18 Mar 2010)
+
+ 18 Mar 2010; Markos Chandras <hwoarang@gentoo.org> +pcmanfm-0.9.3.ebuild:
+ Version bump
*pcmanfm-0.9.2 (13 Mar 2010)
diff --git a/x11-misc/pcmanfm/pcmanfm-0.9.3.ebuild b/x11-misc/pcmanfm/pcmanfm-0.9.3.ebuild
new file mode 100644
index 000000000000..9a5ed1861746
--- /dev/null
+++ b/x11-misc/pcmanfm/pcmanfm-0.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/pcmanfm-0.9.3.ebuild,v 1.1 2010/03/18 17:18:36 hwoarang Exp $
+
+EAPI="2"
+inherit eutils fdo-mime
+
+DESCRIPTION="Fast lightweight tabbed filemanager"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2
+ >=lxde-base/menu-cache-0.3.2
+ x11-misc/shared-mime-info
+ x11-libs/libfm"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ strip-linguas -i "${S}/po"
+ econf --sysconfdir=/etc $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog 'PCmanFM can optionally support the menu://applications/ location.'
+ elog 'You should install lxde-base/lxmenu-data for that functionality.'
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}