summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-03 09:50:41 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-03 09:50:41 +0000
commita4dbb821bf54d969ee6a90c4d0f7e848e1c905b2 (patch)
tree25d37ef94024cfbb81f92c046c860b9d1a4bea9a /x11-misc
parentUse virtual/udev instead of sys-fs/udev wrt #444398 (diff)
downloadgentoo-2-a4dbb821bf54d969ee6a90c4d0f7e848e1c905b2.tar.gz
gentoo-2-a4dbb821bf54d969ee6a90c4d0f7e848e1c905b2.tar.bz2
gentoo-2-a4dbb821bf54d969ee6a90c4d0f7e848e1c905b2.zip
x11-misc/xaos: Add fix for gcc in i686, #445638; http://code.google.com/p/gnuxaos/issues/detail?id=61
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xaos/ChangeLog9
-rw-r--r--x11-misc/xaos/files/xaos-3.5-build-fix-i686.patch20
-rw-r--r--x11-misc/xaos/metadata.xml4
-rw-r--r--x11-misc/xaos/xaos-3.5-r2.ebuild87
4 files changed, 117 insertions, 3 deletions
diff --git a/x11-misc/xaos/ChangeLog b/x11-misc/xaos/ChangeLog
index 9443d1605456..31f89d2f761a 100644
--- a/x11-misc/xaos/ChangeLog
+++ b/x11-misc/xaos/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xaos
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.42 2012/05/05 04:53:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.43 2012/12/03 09:50:41 jlec Exp $
+
+*xaos-3.5-r2 (03 Dec 2012)
+
+ 03 Dec 2012; Justin Lecher <jlec@gentoo.org> +xaos-3.5-r2.ebuild,
+ +files/xaos-3.5-build-fix-i686.patch, metadata.xml:
+ Add fix for gcc in i686, #445638;
+ http://code.google.com/p/gnuxaos/issues/detail?id=61
05 May 2012; Jeff Horelick <jdhore@gentoo.org> xaos-3.5-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-misc/xaos/files/xaos-3.5-build-fix-i686.patch b/x11-misc/xaos/files/xaos-3.5-build-fix-i686.patch
new file mode 100644
index 000000000000..4736dd389b5a
--- /dev/null
+++ b/x11-misc/xaos/files/xaos-3.5-build-fix-i686.patch
@@ -0,0 +1,20 @@
+--- xaos-3.5/src/engine/zoomd.c.orig 2009-07-18 00:50:31.000000000 +0100
++++ xaos-3.5/src/engine/zoomd.c 2012-05-20 19:04:55.891065437 +0100
+@@ -280,6 +280,7 @@ dosymetry2(void /*@unused@ */ *data, str
+ #endif
+ #undef bpp1
+
++REGISTERS(0)
+ static INLINE void fillline(int line)
+ {
+ register unsigned char *RESTRICT vbuff = cimage.currlines[line];
+--- xaos-3.5/src/engine/zoom.c.fix-build 2009-07-18 00:50:31.000000000 +0100
++++ xaos-3.5/src/engine/zoom.c 2012-05-20 19:11:53.625083113 +0100
+@@ -933,6 +933,7 @@ static /*INLINE */ void preparemoveoldpo
+ }
+
+ #ifndef USE_i386ASM
++REGISTERS(0)
+ static /*INLINE */ void
+ moveoldpoints(void /*@unused@ */ *data1,
+ struct taskinfo /*@unused@ */ *task,
diff --git a/x11-misc/xaos/metadata.xml b/x11-misc/xaos/metadata.xml
index 02e05a435d1c..4a15ac2a0569 100644
--- a/x11-misc/xaos/metadata.xml
+++ b/x11-misc/xaos/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
XaoS is a fast, portable real-time interactive fractal zoomer. It
displays the Mandelbrot set (among other escape time fractals) and
allows you zoom smoothly into the fractal. Various coloring modes are
diff --git a/x11-misc/xaos/xaos-3.5-r2.ebuild b/x11-misc/xaos/xaos-3.5-r2.ebuild
new file mode 100644
index 000000000000..b0e664a5faa7
--- /dev/null
+++ b/x11-misc/xaos/xaos-3.5-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.5-r2.ebuild,v 1.1 2012/12/03 09:50:41 jlec Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A very fast real-time fractal zoomer"
+HOMEPAGE="http://xaos.sf.net/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${PN}.png.tar
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aalib doc -gtk nls png svga threads X"
+
+RDEPEND="
+ sci-libs/gsl
+ sys-libs/zlib
+ aalib? ( media-libs/aalib )
+ gtk? ( x11-libs/gtk+:2 )
+ png? ( media-libs/libpng )
+ X? ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-texinfo )
+ X? (
+ x11-proto/xf86vidmodeproto
+ x11-proto/xextproto
+ x11-proto/xproto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.4-png.patch \
+ "${FILESDIR}"/${PN}-3.4-include.patch \
+ "${FILESDIR}"/${P}-libpng15.patch \
+ "${FILESDIR}"/${P}-build-fix-i686.patch
+ sed -i -e 's/-s//' Makefile.in
+ eautoreconf
+}
+
+src_configure() {
+ # use gsl and not nasm (see bug #233318)
+ econf \
+ --with-sffe=yes \
+ --with-gsl=yes \
+ $(use_enable nls) \
+ $(use_with png) \
+ $(use_with aalib aa-driver) \
+ $(use_with gtk gtk-driver) \
+ $(use_with threads pthread) \
+ $(use_with X x11-driver) \
+ $(use_with X x)
+}
+
+src_compile() {
+ default
+ if use doc; then
+ cd "${S}"/doc
+ emake xaos.dvi
+ dvipdf xaos.dvi || die
+ cd "${S}"/help
+ emake html
+ fi
+}
+
+src_install() {
+ default
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/xaos.pdf
+ dohtml -r help/*
+ fi
+ local driver="x11"
+ use gtk && driver="\"GTK+ Driver\""
+ make_desktop_entry "xaos -driver ${driver}" "XaoS Fractal Zoomer" \
+ xaos "Application;Education;Math;Graphics;"
+ doicon "${WORKDIR}"/${PN}.png
+}