summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-26 19:57:39 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-26 19:57:39 +0000
commita2e1981c98cf7fa8753a9a5379b6ca6322cf1bbd (patch)
treeb1fda88c0f0cc54007065308beb30361cac48a18 /x11-misc
parentMask the multilib freetype for testing due to header location change. (diff)
downloadgentoo-2-a2e1981c98cf7fa8753a9a5379b6ca6322cf1bbd.tar.gz
gentoo-2-a2e1981c98cf7fa8753a9a5379b6ca6322cf1bbd.tar.bz2
gentoo-2-a2e1981c98cf7fa8753a9a5379b6ca6322cf1bbd.zip
Version bump (#458822 by Manuel Rüger (mrueg))
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bumblebee/ChangeLog7
-rw-r--r--x11-misc/bumblebee/bumblebee-3.1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/x11-misc/bumblebee/ChangeLog b/x11-misc/bumblebee/ChangeLog
index f0ec931e381d..90d6f14ebe77 100644
--- a/x11-misc/bumblebee/ChangeLog
+++ b/x11-misc/bumblebee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/bumblebee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/ChangeLog,v 1.11 2013/01/21 21:19:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/ChangeLog,v 1.12 2013/02/26 19:57:39 pacho Exp $
+
+*bumblebee-3.1 (26 Feb 2013)
+
+ 26 Feb 2013; Pacho Ramos <pacho@gentoo.org> +bumblebee-3.1.ebuild:
+ Version bump (#458822 by Manuel Rüger (mrueg))
*bumblebee-3.0.1-r2 (21 Jan 2013)
diff --git a/x11-misc/bumblebee/bumblebee-3.1.ebuild b/x11-misc/bumblebee/bumblebee-3.1.ebuild
new file mode 100644
index 000000000000..464f63b14120
--- /dev/null
+++ b/x11-misc/bumblebee/bumblebee-3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bumblebee/bumblebee-3.1.ebuild,v 1.1 2013/02/26 19:57:39 pacho Exp $
+
+EAPI=5
+inherit eutils multilib readme.gentoo systemd user
+
+DESCRIPTION="Service providing elegant and stable means of managing Optimus graphics chipsets"
+HOMEPAGE="http://bumblebee-project.org https://github.com/Bumblebee-Project/Bumblebee"
+SRC_URI="http://bumblebee-project.org/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+bbswitch video_cards_nouveau video_cards_nvidia"
+
+RDEPEND="x11-misc/virtualgl:=
+ bbswitch? ( sys-power/bbswitch )
+ virtual/opengl
+ x11-base/xorg-drivers[video_cards_nvidia?,video_cards_nouveau?]"
+DEPEND=">=sys-devel/autoconf-2.68
+ sys-devel/automake
+ sys-devel/gcc
+ virtual/pkgconfig
+ dev-libs/glib:2
+ x11-libs/libX11
+ dev-libs/libbsd
+ sys-apps/help2man"
+
+REQUIRED_USE="|| ( video_cards_nouveau video_cards_nvidia )"
+
+src_configure() {
+ DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
+ You may need to setup your /etc/bumblebee/bumblebee.conf"
+
+ if use video_cards_nvidia ; then
+ # Get paths to GL libs for all ABIs
+ local nvlib=""
+ for i in $(get_all_libdirs) ; do
+ nvlib="${nvlib}:/usr/${i}/opengl/nvidia/lib"
+ done
+
+ local nvpref="/usr/$(get_libdir)/opengl/nvidia"
+ local xorgpref="/usr/$(get_libdir)/xorg/modules"
+ ECONF_PARAMS="CONF_DRIVER=nvidia CONF_DRIVER_MODULE_NVIDIA=nvidia \
+ CONF_LDPATH_NVIDIA=${nvlib#:} \
+ CONF_MODPATH_NVIDIA=${nvpref}/lib,${nvpref}/extensions,${xorgpref}/drivers,${xorgpref}"
+ fi
+
+ econf \
+ --docdir=/usr/share/doc/"${PF}" \
+ ${ECONF_PARAMS}
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/bumblebee.confd bumblebee
+ newinitd "${FILESDIR}"/bumblebee.initd bumblebee
+ newenvd "${FILESDIR}"/bumblebee.envd 99bumblebee
+ systemd_dounit scripts/systemd/bumblebeed.service
+
+ readme.gentoo_create_doc
+
+ default
+}
+
+pkg_preinst() {
+ use video_cards_nvidia || rm "${ED}"/etc/bumblebee/xorg.conf.nvidia
+ use video_cards_nouveau || rm "${ED}"/etc/bumblebee/xorg.conf.nouveau
+
+ enewgroup bumblebee
+}