summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-12-24 02:56:43 +0000
committerSven Wegener <swegener@gentoo.org>2004-12-24 02:56:43 +0000
commit9b606bdf974fe802882541a987565e79731a5b69 (patch)
tree737af21b65a90d400c259bfe3fe9232c01c48526 /x11-misc
parentMoved from app-sci/spectromatic to media-gfx/spectromatic (diff)
downloadgentoo-2-9b606bdf974fe802882541a987565e79731a5b69.tar.gz
gentoo-2-9b606bdf974fe802882541a987565e79731a5b69.tar.bz2
gentoo-2-9b606bdf974fe802882541a987565e79731a5b69.zip
Version bump.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/x11vnc/ChangeLog7
-rw-r--r--x11-misc/x11vnc/Manifest12
-rw-r--r--x11-misc/x11vnc/files/digest-x11vnc-0.71
-rw-r--r--x11-misc/x11vnc/x11vnc-0.7.ebuild51
4 files changed, 60 insertions, 11 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index 2e64d564dd6f..1dbfb5456f1e 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.2 2004/12/10 00:48:44 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.3 2004/12/24 02:56:43 swegener Exp $
+
+*x11vnc-0.7 (24 Dec 2004)
+
+ 24 Dec 2004; Sven Wegener <swegener@gentoo.org> +x11vnc-0.7.ebuild:
+ Version bump.
10 Dec 2004; Sven Wegener <swegener@gentoo.org> x11vnc-0.6.2.ebuild:
Added to ~hhpa.
diff --git a/x11-misc/x11vnc/Manifest b/x11-misc/x11vnc/Manifest
index 2112a504a407..282cf88ba644 100644
--- a/x11-misc/x11vnc/Manifest
+++ b/x11-misc/x11vnc/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 0f0ea6dcdfd2bead1d932c1e2cb759a8 x11vnc-0.7.ebuild 1223
MD5 0f0ea6dcdfd2bead1d932c1e2cb759a8 x11vnc-0.6.2.ebuild 1223
MD5 fc610f49d0457f0281c2581a795819d3 ChangeLog 487
MD5 8845b35c56be21370ef600f1b3eca775 metadata.xml 470
MD5 2933f74d7e72b3c58eba75f7448c1564 files/digest-x11vnc-0.6.2 64
MD5 bed373def7254533185032fe28580512 files/0.6.2-configure.ac.patch 826
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBuPJyI1lqEGTUzyQRAti+AJ9k454o+/BBvdJkoXiSqOHyzWJxzwCgi8xK
-nZ0+RMYxFJcyqtyNUrU0pF0=
-=+2A9
------END PGP SIGNATURE-----
+MD5 0a51724347b7a0fd71c2f0935671b2c8 files/digest-x11vnc-0.7 62
diff --git a/x11-misc/x11vnc/files/digest-x11vnc-0.7 b/x11-misc/x11vnc/files/digest-x11vnc-0.7
new file mode 100644
index 000000000000..472eed59a01c
--- /dev/null
+++ b/x11-misc/x11vnc/files/digest-x11vnc-0.7
@@ -0,0 +1 @@
+MD5 112d293d1e00df0a28a5da9071215136 x11vnc-0.7.tar.gz 497243
diff --git a/x11-misc/x11vnc/x11vnc-0.7.ebuild b/x11-misc/x11vnc/x11vnc-0.7.ebuild
new file mode 100644
index 000000000000..77df5e5e6097
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.7.ebuild,v 1.1 2004/12/24 02:56:43 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="mirror://sourceforge/libvncserver/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~hppa"
+IUSE="jpeg zlib"
+
+RDEPEND="virtual/x11
+ zlib? ( sys-libs/zlib )
+ jpeg? (
+ media-libs/jpeg
+ sys-libs/zlib
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Hack to avoid running all autotools
+ touch -r configure configure.timestamp
+ touch -r configure.ac configure.ac.timestamp
+
+ epatch ${FILESDIR}/0.6.2-configure.ac.patch
+ WANT_AUTOCONF="2.5" autoconf || die "autoconf failed"
+
+ touch -r configure.timestamp configure
+ touch -r configure.ac.timestamp configure.ac
+}
+
+src_compile() {
+ econf \
+ $(use_with jpeg) \
+ $(use_with jpeg zlib) \
+ $(use_with zlib) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc x11vnc/{ChangeLog,README} || die "dodoc failed"
+}