summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-31 23:32:50 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-31 23:32:50 +0000
commit99365fdbca73f097d9b3574c66dfa8c52b1a5854 (patch)
tree0ae53067fd0769bc57c6b129cef03f4ee2931af1 /x11-misc
parentUpdate EAPI. Fix dependencies. Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-99365fdbca73f097d9b3574c66dfa8c52b1a5854.tar.gz
gentoo-2-99365fdbca73f097d9b3574c66dfa8c52b1a5854.tar.bz2
gentoo-2-99365fdbca73f097d9b3574c66dfa8c52b1a5854.zip
Version bump. Bug #338577
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfe/ChangeLog7
-rw-r--r--x11-misc/xfe/xfe-1.32.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index 60c5b7f1f899..d0721a0eb439 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.62 2010/06/06 12:43:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.63 2010/10/31 23:32:50 hwoarang Exp $
+
+*xfe-1.32.2 (31 Oct 2010)
+
+ 31 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +xfe-1.32.2.ebuild:
+ Version bump. Bug #338577
06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> xfe-1.32.1.ebuild:
Fix testsuite wrt #320791 by Diego E. Pettenò.
diff --git a/x11-misc/xfe/xfe-1.32.2.ebuild b/x11-misc/xfe/xfe-1.32.2.ebuild
new file mode 100644
index 000000000000..936319341845
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.32.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.2.ebuild,v 1.1 2010/10/31 23:32:50 hwoarang Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="x11-libs/libX11
+ media-libs/libpng
+ =x11-libs/fox-1.6*[truetype,png]
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}