summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-06 21:02:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-06 21:02:48 +0000
commit990748182c1b87e8aeee7b9a9414c19a6c82fddc (patch)
tree0378f3ff25668ec75d94388074965bab725fb24d /x11-misc
parentApply patch to fix building with boost >= 1.50. Bug #425422, Thanks to Olivie... (diff)
downloadgentoo-2-990748182c1b87e8aeee7b9a9414c19a6c82fddc.tar.gz
gentoo-2-990748182c1b87e8aeee7b9a9414c19a6c82fddc.tar.bz2
gentoo-2-990748182c1b87e8aeee7b9a9414c19a6c82fddc.zip
Revbump. Drop -Werror. Bug #442048. Don't build libnotify support unconditionally. Bug #441986
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/tinymount/ChangeLog10
-rw-r--r--x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch15
-rw-r--r--x11-misc/tinymount/tinymount-0.2.6-r1.ebuild62
3 files changed, 85 insertions, 2 deletions
diff --git a/x11-misc/tinymount/ChangeLog b/x11-misc/tinymount/ChangeLog
index 1f52d5e56ae3..27613ba94100 100644
--- a/x11-misc/tinymount/ChangeLog
+++ b/x11-misc/tinymount/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/tinymount
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/ChangeLog,v 1.3 2012/11/06 06:39:30 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/ChangeLog,v 1.4 2012/11/06 21:02:47 hwoarang Exp $
+
+*tinymount-0.2.6-r1 (06 Nov 2012)
+
+ 06 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/tinymount-0.2.6-libnotify.patch, +tinymount-0.2.6-r1.ebuild:
+ Revbump. Drop -Werror. Bug #442048. Don't build libnotify support
+ unconditionally. Bug #441986
*tinymount-0.2.6 (06 Nov 2012)
@@ -15,4 +22,3 @@
15 May 2012; Samuli Suominen <ssuominen@gentoo.org> +tinymount-0.2.4.ebuild:
Initial commit wrt #415565 by Mike Limansky
-
diff --git a/x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch b/x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch
new file mode 100644
index 000000000000..9032d3a3eb5a
--- /dev/null
+++ b/x11-misc/tinymount/files/tinymount-0.2.6-libnotify.patch
@@ -0,0 +1,15 @@
+# Don't build with libnotify unconditionally
+# bug #442048
+diff --git a/src/src.pro b/src/src.pro
+index 6a676cd..6b8c2f1 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -63,8 +63,6 @@ RESOURCES += tinymount.qrc
+
+ TRANSLATIONS = translations/tinymount_ru.ts
+
+-CONFIG += with_libnotify
+-
+ with_libnotify {
+ DEFINES += WITH_LIBNOTIFY
+ CONFIG += link_pkgconfig
diff --git a/x11-misc/tinymount/tinymount-0.2.6-r1.ebuild b/x11-misc/tinymount/tinymount-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..66c9d887884b
--- /dev/null
+++ b/x11-misc/tinymount/tinymount-0.2.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinymount/tinymount-0.2.6-r1.ebuild,v 1.1 2012/11/06 21:02:47 hwoarang Exp $
+
+EAPI=4
+
+unset _live_inherits
+
+PLOCALES="ru"
+
+if [[ ${PV} == *9999* ]]; then
+ _live_inherits="git-2"
+ EGIT_REPO_URI="git://github.com/limansky/${PN}.git"
+else
+ SRC_URI="mirror://github/limansky/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit l10n qt4-r2 ${_live_inherits}
+
+DESCRIPTION="Simple disk mount utility"
+HOMEPAGE="http://github.com/limansky/tinymount"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug libnotify"
+
+COMMON_DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-dbus:4
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks:0"
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ remove_locale() {
+ # this is nonfatal sed, so '|| die' unneeded here
+ sed -i -e "/TRANSLATIONS/s/translations\/${PN}_${1}.ts//" src/src.pro
+ }
+
+ # Check for locales added/removed from previous version
+ l10n_find_plocales_changes "src/translations" "${PN}_" '.ts'
+
+ # Prevent disabled locales from being built
+ l10n_for_each_disabled_locale_do remove_locale
+
+ # bug #441986
+ sed -i src/src.pro -e 's|-Werror||g' || die # bug #441986
+
+ epatch "${FILESDIR}"/${P}-libnotify.patch
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local params="PREFIX=/usr"
+ use libnotify && params="${params} CONFIG+=with_libnotify"
+ eqmake4 ${params}
+}