summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-03-21 12:10:24 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-03-21 12:10:24 +0000
commit84bf48cdb3dd8749d7efb0811e6856d3ed1b5295 (patch)
treeabe9771145296ea84922ffe3cd911805082779a9 /x11-misc
parentMissing src_install broke..fixing per 262265 (diff)
downloadgentoo-2-84bf48cdb3dd8749d7efb0811e6856d3ed1b5295.tar.gz
gentoo-2-84bf48cdb3dd8749d7efb0811e6856d3ed1b5295.tar.bz2
gentoo-2-84bf48cdb3dd8749d7efb0811e6856d3ed1b5295.zip
Version bump, see bug #263020.
(Portage version: 2.1.6.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/parcellite/ChangeLog10
-rw-r--r--x11-misc/parcellite/parcellite-0.9.1.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 911356b101e3..678ec57a9a2d 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/parcellite
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.4 2008/12/01 19:31:55 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.5 2009/03/21 12:10:24 nelchael Exp $
+
+*parcellite-0.9.1 (21 Mar 2009)
+
+ 21 Mar 2009; Krzysiek Pawlik <nelchael@gentoo.org>
+ +parcellite-0.9.1.ebuild:
+ Version bump, see bug #263020.
*parcellite-0.9 (01 Dec 2008)
diff --git a/x11-misc/parcellite/parcellite-0.9.1.ebuild b/x11-misc/parcellite/parcellite-0.9.1.ebuild
new file mode 100644
index 000000000000..7956638ec85e
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-0.9.1.ebuild,v 1.1 2009/03/21 12:10:24 nelchael Exp $
+
+inherit fdo-mime
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable nls)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}