summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-03 15:23:50 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-03 15:23:50 +0000
commit84244d2eba196c84902475a324ec3ce1d46793f4 (patch)
tree46d11bc52975d59699d14e913f62c5769d7e9ecf /x11-misc
parentVersion bump with tons of fixes and some new features. (diff)
downloadgentoo-2-84244d2eba196c84902475a324ec3ce1d46793f4.tar.gz
gentoo-2-84244d2eba196c84902475a324ec3ce1d46793f4.tar.bz2
gentoo-2-84244d2eba196c84902475a324ec3ce1d46793f4.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dmenu/ChangeLog7
-rw-r--r--x11-misc/dmenu/dmenu-4.1.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index 1bc9c5641408..3e6c10777117 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.58 2010/06/22 15:09:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.59 2010/07/03 15:23:50 jer Exp $
+
+*dmenu-4.1.1 (03 Jul 2010)
+
+ 03 Jul 2010; Jeroen Roovers <jer@gentoo.org> +dmenu-4.1.1.ebuild:
+ Version bump.
22 Jun 2010; Jeroen Roovers <jer@gentoo.org> dmenu-4.0.ebuild:
Marked ~hppa (bug #323039).
diff --git a/x11-misc/dmenu/dmenu-4.1.1.ebuild b/x11-misc/dmenu/dmenu-4.1.1.ebuild
new file mode 100644
index 000000000000..ae009466873f
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-4.1.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-4.1.1.ebuild,v 1.1 2010/07/03 15:23:50 jer Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed${msg}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}