summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2014-01-07 22:28:10 +0000
committerMatthew Marlowe <mattm@gentoo.org>2014-01-07 22:28:10 +0000
commit82040cff469fb8f27ddea909564cc760ca3fc01c (patch)
tree9d08ef313712b2d688c8f099c790899466ebae37 /x11-misc
parentInitial import into main tree (diff)
downloadgentoo-2-82040cff469fb8f27ddea909564cc760ca3fc01c.tar.gz
gentoo-2-82040cff469fb8f27ddea909564cc760ca3fc01c.tar.bz2
gentoo-2-82040cff469fb8f27ddea909564cc760ca3fc01c.zip
Fix python eclass inherit compatibility, bump for version 1.8.0, starting stable request for 1.6.6-r1
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 786037A7)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rednotebook/ChangeLog11
-rw-r--r--x11-misc/rednotebook/rednotebook-1.4.0.ebuild4
-rw-r--r--x11-misc/rednotebook/rednotebook-1.6.6-r1.ebuild (renamed from x11-misc/rednotebook/rednotebook-1.6.6.ebuild)8
-rw-r--r--x11-misc/rednotebook/rednotebook-1.8.0.ebuild33
4 files changed, 49 insertions, 7 deletions
diff --git a/x11-misc/rednotebook/ChangeLog b/x11-misc/rednotebook/ChangeLog
index 83f6fe5366b7..30e29ae53f28 100644
--- a/x11-misc/rednotebook/ChangeLog
+++ b/x11-misc/rednotebook/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-misc/rednotebook
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.69 2014/01/01 13:12:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/ChangeLog,v 1.70 2014/01/07 22:28:10 mattm Exp $
+
+*rednotebook-1.8.0 (07 Jan 2014)
+*rednotebook-1.6.6-r1 (07 Jan 2014)
+
+ 07 Jan 2014; Matthew Marlowe <mattm@gentoo.org> +rednotebook-1.6.6-r1.ebuild,
+ +rednotebook-1.8.0.ebuild, -rednotebook-1.6.6.ebuild,
+ rednotebook-1.4.0.ebuild:
+ Fix python eclass inherit compatibility, bump for version 1.8.0, starting
+ stable request for 1.6.6-r1
01 Jan 2014; Markos Chandras <hwoarang@gentoo.org> -rednotebook-1.6.2.ebuild,
-rednotebook-1.6.5.ebuild:
diff --git a/x11-misc/rednotebook/rednotebook-1.4.0.ebuild b/x11-misc/rednotebook/rednotebook-1.4.0.ebuild
index 93cb10c30ea8..46de7ddfcb8a 100644
--- a/x11-misc/rednotebook/rednotebook-1.4.0.ebuild
+++ b/x11-misc/rednotebook/rednotebook-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.4.0.ebuild,v 1.3 2012/06/20 14:42:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.4.0.ebuild,v 1.4 2014/01/07 22:28:10 mattm Exp $
EAPI="3"
diff --git a/x11-misc/rednotebook/rednotebook-1.6.6.ebuild b/x11-misc/rednotebook/rednotebook-1.6.6-r1.ebuild
index b3f7239969f8..a9fbf5f23f8f 100644
--- a/x11-misc/rednotebook/rednotebook-1.6.6.ebuild
+++ b/x11-misc/rednotebook/rednotebook-1.6.6-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.6.6.ebuild,v 1.1 2013/01/26 17:53:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.6.6-r1.ebuild,v 1.1 2014/01/07 22:28:10 mattm Exp $
EAPI="4"
-PYTHON_DEPEND="2:2.6"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python eutils distutils
+inherit python-r1 eutils distutils-r1
DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
HOMEPAGE="http://rednotebook.sourceforge.net"
diff --git a/x11-misc/rednotebook/rednotebook-1.8.0.ebuild b/x11-misc/rednotebook/rednotebook-1.8.0.ebuild
new file mode 100644
index 000000000000..5e344db742eb
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rednotebook/rednotebook-1.8.0.ebuild,v 1.1 2014/01/07 22:28:10 mattm Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 eutils distutils-r1
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="libyaml spell"
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/chardet
+ spell? ( dev-python/gtkspell-python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${PN}-1.6.5-disable-spell.patch"
+ distutils_src_prepare
+}