summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2004-06-02 12:56:53 +0000
committerIan Leitch <port001@gentoo.org>2004-06-02 12:56:53 +0000
commit7d5df72ce748a5d65b7323497df583e7ff3cb742 (patch)
treeb5c1b1d8116c3134deac589b5712336ab9b4e979 /x11-misc
parentAdded patches for the CAN-2004-0075, CAN-2004-0181, CAN-2004-0394, and CAN-20... (diff)
downloadgentoo-2-7d5df72ce748a5d65b7323497df583e7ff3cb742.tar.gz
gentoo-2-7d5df72ce748a5d65b7323497df583e7ff3cb742.tar.bz2
gentoo-2-7d5df72ce748a5d65b7323497df583e7ff3cb742.zip
Version bump, #51851
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xplanet/ChangeLog7
-rw-r--r--x11-misc/xplanet/Manifest2
-rw-r--r--x11-misc/xplanet/files/digest-xplanet-1.0.81
-rw-r--r--x11-misc/xplanet/xplanet-1.0.8.ebuild72
4 files changed, 81 insertions, 1 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 66946a500ec2..1316bcef9c7f 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xplanet
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.22 2004/05/26 15:15:20 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.23 2004/06/02 12:56:53 port001 Exp $
+
+*xplanet-1.0.8 (02 Jun 2004)
+
+ 02 Jun 2004; Ian Leitch <port001@gentoo.org> +xplanet-1.0.8.ebuild:
+ Version bump, #51851
26 May 2004; Ian Leitch <port001@gentoo.org> xplanet-0.94-r1.ebuild,
xplanet-1.0.1.ebuild, xplanet-1.0.3.ebuild:
diff --git a/x11-misc/xplanet/Manifest b/x11-misc/xplanet/Manifest
index b1030ed6e635..ef7bfd3f9493 100644
--- a/x11-misc/xplanet/Manifest
+++ b/x11-misc/xplanet/Manifest
@@ -1,4 +1,5 @@
MD5 51aac6053a1f29aa00946a5dcfb32fbf xplanet-1.0.1.ebuild 1778
+MD5 db87eb0e9b52ff5103cf765f73f8e967 xplanet-1.0.8.ebuild 1728
MD5 ad880cfba10fd31a60bff3796af342fb xplanet-1.0.3.ebuild 1766
MD5 19143a4a13864a82f0926790754b9f7e ChangeLog 3676
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
@@ -7,3 +8,4 @@ MD5 d977ccdeaa9865add9959757f7d0acd9 files/0.94-gcc3.patch 329
MD5 8f91c563012b8a0cb7bc11bd0c469a86 files/digest-xplanet-0.94-r1 65
MD5 ad06a8c07b9a4ae7dd405ac2a2632415 files/digest-xplanet-1.0.1 65
MD5 644dc5f6094b07739558df5295c25d20 files/digest-xplanet-1.0.3 66
+MD5 1187571ef0c05b6c37346ba713775f50 files/digest-xplanet-1.0.8 66
diff --git a/x11-misc/xplanet/files/digest-xplanet-1.0.8 b/x11-misc/xplanet/files/digest-xplanet-1.0.8
new file mode 100644
index 000000000000..e534e0096119
--- /dev/null
+++ b/x11-misc/xplanet/files/digest-xplanet-1.0.8
@@ -0,0 +1 @@
+MD5 243988afd8c76d9d4c0ab5201981ab6e xplanet-1.0.8.tar.gz 1175294
diff --git a/x11-misc/xplanet/xplanet-1.0.8.ebuild b/x11-misc/xplanet/xplanet-1.0.8.ebuild
new file mode 100644
index 000000000000..25c04395c73b
--- /dev/null
+++ b/x11-misc/xplanet/xplanet-1.0.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.0.8.ebuild,v 1.1 2004/06/02 12:56:53 port001 Exp $
+
+DESCRIPTION="A program to render images of the earth into the X root window"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://xplanet.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gif jpeg X opengl truetype tiff png"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl
+ media-libs/glut )
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ truetype? ( =media-libs/freetype-2* )"
+
+src_unpack() {
+ unpack ${A}
+ # fix GCC3.2 include re-ordering bug.
+ cd ${S}
+ sed -i 's,-I$prefix/include,,' configure
+}
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="$myconf --with-x" \
+ || myconf="$myconf --with-x=no"
+
+ use opengl \
+ && myconf="--with-gl --with-glut --with-animation" \
+ || myconf="--with-gl=no --with-glut=no --with-animation=no"
+
+ use gif \
+ && myconf="$myconf --with-gif" \
+ || myconf="$myconf --with-gif=no"
+
+ use jpeg \
+ && myconf="${myconf} --with-jpeg" \
+ || myconf="${myconf} --with-jpeg=no"
+
+ use tiff \
+ && myconf="${myconf} --with-tiff" \
+ || myconf="${myconf} --with-tiff=no"
+
+ use png \
+ && myconf="${myconf} --with-png --with-pnm" \
+ || myconf="${myconf} --with-png=no --with-pnm=no"
+
+ use truetype \
+ && myconf="${myconf} --with-freetype" \
+ || myconf="${myconf} --with-freetype=no"
+
+ econf ${myconf} || die
+
+ # xplanet doesn't like to build parallel
+ make || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc README COPYING INSTALL NEWS ChangeLog
+}