summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-10 19:23:49 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-10 19:23:49 +0000
commit6f6bd704f2f3fe5d8893e76307c0e8e8e0d5022e (patch)
tree417d08bd12c14671b48d96ece6a1e27e5bbe099b /x11-misc
parentamd64 stable wrt bug #471912 (diff)
downloadgentoo-2-6f6bd704f2f3fe5d8893e76307c0e8e8e0d5022e.tar.gz
gentoo-2-6f6bd704f2f3fe5d8893e76307c0e8e8e0d5022e.tar.bz2
gentoo-2-6f6bd704f2f3fe5d8893e76307c0e8e8e0d5022e.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/i3lock/ChangeLog9
-rw-r--r--x11-misc/i3lock/i3lock-2.5.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/x11-misc/i3lock/ChangeLog b/x11-misc/i3lock/ChangeLog
index b8ac8beb0a79..a89c5942a458 100644
--- a/x11-misc/i3lock/ChangeLog
+++ b/x11-misc/i3lock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/i3lock
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3lock/ChangeLog,v 1.13 2012/08/21 11:30:08 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3lock/ChangeLog,v 1.14 2013/06/10 19:23:49 jer Exp $
+
+*i3lock-2.5 (10 Jun 2013)
+
+ 10 Jun 2013; Jeroen Roovers <jer@gentoo.org> +i3lock-2.5.ebuild:
+ Version bump.
21 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org> -i3lock-2.2.ebuild,
-i3lock-2.4.ebuild:
diff --git a/x11-misc/i3lock/i3lock-2.5.ebuild b/x11-misc/i3lock/i3lock-2.5.ebuild
new file mode 100644
index 000000000000..652298a9734f
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3lock/i3lock-2.5.ebuild,v 1.1 2013/06/10 19:23:49 jer Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libev
+ virtual/pam
+ x11-libs/cairo[xcb]
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/xcb-util-image
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( README )
+
+src_prepare() {
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+ tc-export CC
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}