summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-12-22 16:15:07 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-12-22 16:15:07 +0000
commit66d9822ec40b412432135c8a558cddc17bccfde7 (patch)
tree3dba11b63581526c2df92ae4048eb9a0c9642a41 /x11-misc
parentppc stable, bug #201682 (diff)
downloadgentoo-2-66d9822ec40b412432135c8a558cddc17bccfde7.tar.gz
gentoo-2-66d9822ec40b412432135c8a558cddc17bccfde7.tar.bz2
gentoo-2-66d9822ec40b412432135c8a558cddc17bccfde7.zip
~arch commit
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/googleearth/files/digest-googleearth-4.2.205.57303
-rw-r--r--x11-misc/googleearth/googleearth-4.2.205.5730.ebuild80
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-misc/googleearth/files/digest-googleearth-4.2.205.5730 b/x11-misc/googleearth/files/digest-googleearth-4.2.205.5730
new file mode 100644
index 000000000000..420d83ec3cdd
--- /dev/null
+++ b/x11-misc/googleearth/files/digest-googleearth-4.2.205.5730
@@ -0,0 +1,3 @@
+MD5 789f438a999dfb157dc89eaa90388ac4 GoogleEarthLinux.bin 23048189
+RMD160 bf8994f6aa9f4204510023ac629c331789e3969b GoogleEarthLinux.bin 23048189
+SHA256 da7d22cb13cc5f047dea6ae241bb33c5ac1789a9f601e09dcb025fe574df4516 GoogleEarthLinux.bin 23048189
diff --git a/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild b/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild
new file mode 100644
index 000000000000..7be089ec0d4f
--- /dev/null
+++ b/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-4.2.205.5730.ebuild,v 1.1 2007/12/22 16:15:07 genstef Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin"
+
+LICENSE="googleearth MIT X11 SGI-B-1.1 openssl as-is ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE=""
+
+RDEPEND="x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-baselibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ <x11-drivers/ati-drivers-8.28.8 ) )
+ media-fonts/ttf-bitstream-vera"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_makeself
+ # make the postinst script only create the files; it's installation
+ # are too complicated and inserting them ourselves is easier than
+ # hacking around it
+ sed -i -e 's:$SETUP_INSTALLPATH/::' \
+ -e 's:$SETUP_INSTALLPATH:1:' \
+ -e "s:^xdg-desktop-icon.*$::" \
+ -e "s:^xdg-desktop-menu.*$::" \
+ -e "s:^xdg-mime.*$::" postinstall.sh
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+ ./postinstall.sh
+ insinto /usr/share/mime/packages
+ doins ${PN}-mimetypes.xml
+ domenu Google-${PN}.desktop
+ doicon ${PN}-icon.png
+ dodoc README.linux
+
+ cd bin
+ tar xf ${WORKDIR}/${PN}-linux-x86.tar
+ exeinto /opt/${PN}
+ doexe *
+
+ cd ${D}/opt/${PN}
+ tar xf ${WORKDIR}/${PN}-data.tar
+
+ cd ${D}
+ # mime magic for gnome by Ed Catmur in bug 141371
+ epatch ${FILESDIR}/mime-magic.patch
+
+ # make sure we install with correct permissions
+ fowners -R root:root /opt/${PN}
+ fperms -R a-x,a+X /opt/googleearth/{xml,res{,ources}}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}