summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-01 19:31:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-01 19:31:55 +0000
commit414ce61eec5dcf1a801da7b54e8bc9500d86c506 (patch)
treec1da2cf3e745239cfa31a2ed3ea21f57adb46e19 /x11-misc
parentstable sparc (diff)
downloadgentoo-2-414ce61eec5dcf1a801da7b54e8bc9500d86c506.tar.gz
gentoo-2-414ce61eec5dcf1a801da7b54e8bc9500d86c506.tar.bz2
gentoo-2-414ce61eec5dcf1a801da7b54e8bc9500d86c506.zip
Version bump for bug 249284, thanks to Roman V. Prikhodchenko for reporting.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/parcellite/ChangeLog8
-rw-r--r--x11-misc/parcellite/parcellite-0.9.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 1ede078c3cca..911356b101e3 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.3 2008/09/15 20:35:47 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.4 2008/12/01 19:31:55 ssuominen Exp $
+
+*parcellite-0.9 (01 Dec 2008)
+
+ 01 Dec 2008; <ssuominen@gentoo.org> +parcellite-0.9.ebuild:
+ Version bump for bug 249284, thanks to Roman V. Prikhodchenko for
+ reporting.
*parcellite-0.8 (15 Sep 2008)
diff --git a/x11-misc/parcellite/parcellite-0.9.ebuild b/x11-misc/parcellite/parcellite-0.9.ebuild
new file mode 100644
index 000000000000..4595768ea0ed
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-0.9.ebuild,v 1.1 2008/12/01 19:31:55 ssuominen Exp $
+
+inherit fdo-mime
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable nls)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}