summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-06-10 01:58:50 +0000
committerJim Ramsay <lack@gentoo.org>2007-06-10 01:58:50 +0000
commit35f896f46b6e991bda773bd0027c65b979ebdefa (patch)
tree1f557e8c0168668aea2854ec688b2ad3a9c69ba7 /x11-misc
parentRemoving violinstrings to java junkyard. (diff)
downloadgentoo-2-35f896f46b6e991bda773bd0027c65b979ebdefa.tar.gz
gentoo-2-35f896f46b6e991bda773bd0027c65b979ebdefa.tar.bz2
gentoo-2-35f896f46b6e991bda773bd0027c65b979ebdefa.zip
Bug 178525 - Added patch which fixes 64-bit Xlib bug
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wmctrl/ChangeLog10
-rw-r--r--x11-misc/wmctrl/files/amd64-Xlib.patch28
-rw-r--r--x11-misc/wmctrl/files/digest-wmctrl-1.07-r13
-rw-r--r--x11-misc/wmctrl/wmctrl-1.07-r1.ebuild33
4 files changed, 72 insertions, 2 deletions
diff --git a/x11-misc/wmctrl/ChangeLog b/x11-misc/wmctrl/ChangeLog
index a89eb74cfbd8..19b237291e93 100644
--- a/x11-misc/wmctrl/ChangeLog
+++ b/x11-misc/wmctrl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wmctrl
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmctrl/ChangeLog,v 1.13 2006/10/28 22:24:01 omp Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmctrl/ChangeLog,v 1.14 2007/06/10 01:58:50 lack Exp $
+
+*wmctrl-1.07-r1 (10 Jun 2007)
+
+ 10 Jun 2007; Jim Ramsay <lack@gentoo.org> +files/amd64-Xlib.patch,
+ +wmctrl-1.07-r1.ebuild:
+ Bug 178525 - Added patch which fixes 64-bit Xlib bug
28 Oct 2006; David Shakaryan <omp@gentoo.org> wmctrl-1.07.ebuild:
Remove monolithic X support, fix quotes, don't dodoc COPYING/INSTALL and add
diff --git a/x11-misc/wmctrl/files/amd64-Xlib.patch b/x11-misc/wmctrl/files/amd64-Xlib.patch
new file mode 100644
index 000000000000..a1039a825023
--- /dev/null
+++ b/x11-misc/wmctrl/files/amd64-Xlib.patch
@@ -0,0 +1,28 @@
+--- wmctrl-1.07.orig/main.c
++++ wmctrl-1.07/main.c
+@@ -1425,6 +1425,16 @@
+ *
+ * long_length = Specifies the length in 32-bit multiples of the
+ * data to be retrieved.
++ *
++ * NOTE: see
++ * http://mail.gnome.org/archives/wm-spec-list/2003-March/msg00067.html
++ * In particular:
++ *
++ * When the X window system was ported to 64-bit architectures, a
++ * rather peculiar design decision was made. 32-bit quantities such
++ * as Window IDs, atoms, etc, were kept as longs in the client side
++ * APIs, even when long was changed to 64 bits.
++ *
+ */
+ if (XGetWindowProperty(disp, win, xa_prop_name, 0, MAX_PROPERTY_VALUE_LEN / 4, False,
+ xa_prop_type, &xa_ret_type, &ret_format,
+@@ -1441,6 +1451,8 @@
+
+ /* null terminate the result to make string handling easier */
+ tmp_size = (ret_format / 8) * ret_nitems;
++ /* Correct 64 Architecture implementation of 32 bit data */
++ if(ret_format==32) tmp_size *= sizeof(long)/4;
+ ret = g_malloc(tmp_size + 1);
+ memcpy(ret, ret_prop, tmp_size);
+ ret[tmp_size] = '\0';
diff --git a/x11-misc/wmctrl/files/digest-wmctrl-1.07-r1 b/x11-misc/wmctrl/files/digest-wmctrl-1.07-r1
new file mode 100644
index 000000000000..1b73389e3078
--- /dev/null
+++ b/x11-misc/wmctrl/files/digest-wmctrl-1.07-r1
@@ -0,0 +1,3 @@
+MD5 1fe3c7a2caa6071e071ba34f587e1555 wmctrl-1.07.tar.gz 87820
+RMD160 b19b23c7368875b62ffef71780915b439b2c09d5 wmctrl-1.07.tar.gz 87820
+SHA256 d78a1efdb62f18674298ad039c5cbdb1edb6e8e149bb3a8e3a01a4750aa3cca9 wmctrl-1.07.tar.gz 87820
diff --git a/x11-misc/wmctrl/wmctrl-1.07-r1.ebuild b/x11-misc/wmctrl/wmctrl-1.07-r1.ebuild
new file mode 100644
index 000000000000..26515195fa66
--- /dev/null
+++ b/x11-misc/wmctrl/wmctrl-1.07-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmctrl/wmctrl-1.07-r1.ebuild,v 1.1 2007/06/10 01:58:50 lack Exp $
+
+inherit eutils
+
+DESCRIPTION="command line tool to interact with an EWMH/NetWM compatible X Window Manager"
+HOMEPAGE="http://sweb.cz/tripie/utils/wmctrl/"
+SRC_URI="http://sweb.cz/tripie/utils/wmctrl/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/amd64-Xlib.patch" || die "Patch failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}