summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-01-27 16:57:53 +0000
committerBen de Groot <yngwin@gentoo.org>2013-01-27 16:57:53 +0000
commit2eee9a150a6c1c010e71cc3dd2a2dfa65596d6d3 (patch)
tree032350e5efa35563a101a4aabef313c08a58363f /x11-misc
parentfixed i18n issues; eapi=5; vdr-plugin-2.eclass; compilefix >=vdr-1.7.33 (diff)
downloadgentoo-2-2eee9a150a6c1c010e71cc3dd2a2dfa65596d6d3.tar.gz
gentoo-2-2eee9a150a6c1c010e71cc3dd2a2dfa65596d6d3.tar.bz2
gentoo-2-2eee9a150a6c1c010e71cc3dd2a2dfa65596d6d3.zip
Add greeters as pdepend to fix bug #453702. Implement readme.gentoo elog handling. Drop keywords of arches that don't have greeters keyworded.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/lightdm/ChangeLog9
-rw-r--r--x11-misc/lightdm/files/README.gentoo11
-rw-r--r--x11-misc/lightdm/lightdm-1.4.0-r1.ebuild101
-rw-r--r--x11-misc/lightdm/metadata.xml3
4 files changed, 123 insertions, 1 deletions
diff --git a/x11-misc/lightdm/ChangeLog b/x11-misc/lightdm/ChangeLog
index 55598b53a760..5f256a5fbfa3 100644
--- a/x11-misc/lightdm/ChangeLog
+++ b/x11-misc/lightdm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/lightdm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.59 2013/01/26 13:38:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.60 2013/01/27 16:57:53 yngwin Exp $
+
+*lightdm-1.4.0-r1 (27 Jan 2013)
+
+ 27 Jan 2013; Ben de Groot <yngwin@gentoo.org> +files/README.gentoo,
+ +lightdm-1.4.0-r1.ebuild, metadata.xml:
+ Add greeters as pdepend to fix bug #453702. Implement readme.gentoo elog
+ handling. Drop keywords of arches that don't have greeters keyworded.
26 Jan 2013; Agostino Sarubbo <ago@gentoo.org> lightdm-1.4.0.ebuild:
Stable for arm, wrt bug #452950
diff --git a/x11-misc/lightdm/files/README.gentoo b/x11-misc/lightdm/files/README.gentoo
new file mode 100644
index 000000000000..182f53087548
--- /dev/null
+++ b/x11-misc/lightdm/files/README.gentoo
@@ -0,0 +1,11 @@
+
+ * Even though the default /etc/lightdm/lightdm.conf will work for
+ * most users, make sure you configure it to suit your needs
+ * before using lightdm for the first time.
+ * You can test the configuration file using the following
+ * command: lightdm --test-mode -c /etc/lightdm/lightdm.conf. This
+ * requires xorg-server to be built with the 'kdrive' useflag.
+ *
+ * You can also set your own default values for LIGHTDM_GREETER,
+ * LIGHTDM_SESSION, and LIGHTDM_USER in /etc/portage/make.conf
+
diff --git a/x11-misc/lightdm/lightdm-1.4.0-r1.ebuild b/x11-misc/lightdm/lightdm-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..fab7e682be3e
--- /dev/null
+++ b/x11-misc/lightdm/lightdm-1.4.0-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-1.4.0-r1.ebuild,v 1.1 2013/01/27 16:57:53 yngwin Exp $
+
+EAPI=5
+inherit autotools eutils pam readme.gentoo
+
+TRUNK_VERSION="1.4"
+DESCRIPTION="A lightweight display manager"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM"
+SRC_URI="http://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.gz
+ mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk +introspection kde qt4 razor"
+REQUIRED_USE="|| ( gtk kde razor )"
+
+COMMON_DEPEND=">=dev-libs/glib-2.32.3:2
+ dev-libs/libxml2
+ sys-apps/accountsservice
+ virtual/pam
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ )"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/pambase-20101024-r2"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig"
+PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
+ kde? ( x11-misc/lightdm-kde )
+ razor? ( razorqt-base/razorqt-lightdm-greeter )"
+
+DOCS=( NEWS )
+
+src_prepare() {
+ sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
+ sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die
+
+ epatch "${FILESDIR}"/session-wrapper-${PN}.patch
+ epatch "${FILESDIR}"/${PN}-1.2.0-fix-configure.patch
+ epatch_user
+
+ # Remove bogus Makefile statement. This needs to go upstream
+ sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
+ if has_version dev-libs/gobject-introspection; then
+ eautoreconf
+ else
+ AT_M4DIR=${WORKDIR} eautoreconf
+ fi
+}
+
+src_configure() {
+ # Set default values if global vars unset
+ local _greeter _session _user
+ _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
+ _session=${LIGHTDM_SESSION:=gnome}
+ _user=${LIGHTDM_USER:=root}
+ # Let user know how lightdm is configured
+ einfo "Gentoo configuration"
+ einfo "Default greeter: ${_greeter}"
+ einfo "Default session: ${_session}"
+ einfo "Greeter user: ${_user}"
+
+ econf \
+ --localstatedir=/var \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable qt4 liblightdm-qt) \
+ --with-user-session=${_session} \
+ --with-greeter-session=${_greeter} \
+ --with-greeter-user=${_user} \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ insinto /etc/${PN}
+ doins data/{${PN},keys}.conf
+ doins "${FILESDIR}"/Xsession
+ fperms +x /etc/${PN}/Xsession
+
+ prune_libtool_files --all
+ rm -rf "${ED}"/etc/init
+
+ pamd_mimic system-local-login ${PN} auth account session #372229
+ dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163
+
+ readme.gentoo_create_doc
+}
diff --git a/x11-misc/lightdm/metadata.xml b/x11-misc/lightdm/metadata.xml
index 1e82db0f8688..f251fe5e73fd 100644
--- a/x11-misc/lightdm/metadata.xml
+++ b/x11-misc/lightdm/metadata.xml
@@ -11,7 +11,10 @@
</maintainer>
<use>
<flag name="branding">Replace original gnome background with one from Gentoo ten project</flag>
+ <flag name="gtk">Pull in the gtk+ greeter</flag>
<flag name="introspection">Use dev-libs/gobject-introspection for introspection</flag>
+ <flag name="kde">Pull in the kde greeter</flag>
+ <flag name="razor">Pull in the razorqt greeter</flag>
</use>
<longdescription lang="en">
</longdescription>