summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-16 19:08:26 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-16 19:08:26 +0000
commit2e75ae66c0fbbd26cc54f33e611050b42bbe723b (patch)
tree82388f9951ff89b5e40cf582308cc7f224e194d5 /x11-misc
parentVersion bump, from new upstream (diff)
downloadgentoo-2-2e75ae66c0fbbd26cc54f33e611050b42bbe723b.tar.gz
gentoo-2-2e75ae66c0fbbd26cc54f33e611050b42bbe723b.tar.bz2
gentoo-2-2e75ae66c0fbbd26cc54f33e611050b42bbe723b.zip
Version bump, bug #162142
(Portage version: 2.1.2)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/revelation/ChangeLog7
-rw-r--r--x11-misc/revelation/files/digest-revelation-0.4.113
-rw-r--r--x11-misc/revelation/revelation-0.4.11.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-misc/revelation/ChangeLog b/x11-misc/revelation/ChangeLog
index 46ac1aec10f7..5f895fd5466f 100644
--- a/x11-misc/revelation/ChangeLog
+++ b/x11-misc/revelation/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/revelation
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.2 2007/01/01 11:33:24 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.3 2007/01/16 19:08:26 nyhm Exp $
+
+*revelation-0.4.11 (16 Jan 2007)
+
+ 16 Jan 2007; Tristan Heaven <nyhm@gentoo.org> +revelation-0.4.11.ebuild:
+ Version bump, bug #162142
01 Jan 2007; Tobias Scherbaum <dertobi123@gentoo.org>
revelation-0.4.7.ebuild:
diff --git a/x11-misc/revelation/files/digest-revelation-0.4.11 b/x11-misc/revelation/files/digest-revelation-0.4.11
new file mode 100644
index 000000000000..1ab3660fee94
--- /dev/null
+++ b/x11-misc/revelation/files/digest-revelation-0.4.11
@@ -0,0 +1,3 @@
+MD5 e2db4a2f00f59b18798d4453c778129f revelation-0.4.11.tar.bz2 639842
+RMD160 7253dd746cb992cd9bdb8220ee03a1dad6b2af5d revelation-0.4.11.tar.bz2 639842
+SHA256 82c321ed75dbb6f6e36afd3275598cae3d880fab60c7a0ec6ead08184635efeb revelation-0.4.11.tar.bz2 639842
diff --git a/x11-misc/revelation/revelation-0.4.11.ebuild b/x11-misc/revelation/revelation-0.4.11.ebuild
new file mode 100644
index 000000000000..15cceec21064
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.11.ebuild,v 1.1 2007/01/16 19:08:26 nyhm Exp $
+
+inherit python gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://oss.codepoet.no/revelation/"
+SRC_URI="ftp://oss.codepoet.no/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/gnome-python-desktop-2.16
+ >=dev-python/pygtk-2.10.3
+ dev-python/pycrypto
+ sys-libs/cracklib"
+
+src_unpack() {
+ gnome2_src_unpack
+ ln -sf /bin/true py-compile
+}
+
+src_compile() {
+ gnome2_src_compile \
+ --disable-dependency-tracking \
+ --disable-desktop-update \
+ --disable-mime-update
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO" gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize "${ROOT}"/usr/lib/python${PYVER}/site-packages/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup
+}