summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-01 23:02:59 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-01 23:02:59 +0000
commit1d42f8fece90a66260c554f55490c7ce7ef48ebb (patch)
tree51ee2d9335221cd3b4647f03a287daa9db6a9a7b /x11-misc
parentVersion bump. (diff)
downloadgentoo-2-1d42f8fece90a66260c554f55490c7ce7ef48ebb.tar.gz
gentoo-2-1d42f8fece90a66260c554f55490c7ce7ef48ebb.tar.bz2
gentoo-2-1d42f8fece90a66260c554f55490c7ce7ef48ebb.zip
Version bump.
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xlockmore/ChangeLog7
-rw-r--r--x11-misc/xlockmore/xlockmore-5.34.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/x11-misc/xlockmore/ChangeLog b/x11-misc/xlockmore/ChangeLog
index af77626d0d5f..cb1b86fc7014 100644
--- a/x11-misc/xlockmore/ChangeLog
+++ b/x11-misc/xlockmore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xlockmore
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.92 2011/05/27 11:36:01 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.93 2011/08/01 23:02:59 jer Exp $
+
+*xlockmore-5.34 (01 Aug 2011)
+
+ 01 Aug 2011; Jeroen Roovers <jer@gentoo.org> +xlockmore-5.34.ebuild:
+ Version bump.
27 May 2011; Michael Weber <xmw@gentoo.org> xlockmore-5.31.ebuild:
added ~arm keyword (bug 368715)
diff --git a/x11-misc/xlockmore/xlockmore-5.34.ebuild b/x11-misc/xlockmore/xlockmore-5.34.ebuild
new file mode 100644
index 000000000000..6270a5e17b19
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.34.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.34.ebuild,v 1.1 2011/08/01 23:02:59 jer Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/${PN}/${P}/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug esd gtk motif nas opengl pam truetype xinerama xlockrc"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXmu
+ opengl? ( media-libs/mesa
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 ) )
+ truetype? ( media-libs/freetype:2 )
+ pam? ( virtual/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( >=x11-libs/openmotif-2.3:0 )
+ gtk? ( x11-libs/gtk+:2 )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xineramaproto"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-5.31-configure.in.patch \
+ "${FILESDIR}"/${PN}-5.31-ldflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+
+ if use opengl && use truetype; then
+ myconf="${myconf} --with-ftgl"
+ append-flags -DFTGL213
+ else
+ myconf="${myconf} --without-ftgl"
+ fi
+
+ econf \
+ --enable-vtlock \
+ --enable-syslog \
+ $(use_enable xlockrc) \
+ $(use_enable pam) \
+ --disable-use-mb \
+ --enable-appdefaultdir=/usr/share/X11/app-defaults \
+ $(use_with motif) \
+ $(use_with debug editres) \
+ $(use_with truetype ttf) \
+ $(use_with truetype freetype) \
+ $(use_with opengl) \
+ $(use_with opengl mesa) \
+ $(use_with xinerama) \
+ $(use_with esd esound) \
+ $(use_with nas) \
+ $(use_with crypt) \
+ $(use_with gtk gtk2) \
+ --without-gtk \
+ ${myconf}
+}
+
+src_install() {
+ einstall xapploaddir="${D}/usr/share/X11/app-defaults" \
+ mandir="${D}/usr/share/man/man1" INSTPGMFLAGS="" \
+ || die "einstall failed"
+
+ pamd_mimic_system xlock auth
+
+ if use pam; then
+ fperms 755 /usr/bin/xlock
+ else
+ fperms 4755 /usr/bin/xlock
+ fi
+
+ dohtml docs/xlock.html
+ dodoc README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO}
+}