summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2004-04-26 03:05:46 +0000
committerSteve Arnold <nerdboy@gentoo.org>2004-04-26 03:05:46 +0000
commit17b5c22dc3dd90ebfbda5ba83e3f9c8b82adf698 (patch)
tree64ac23844fee6d19f4fb9c6fc1ed4918b6b00f4b /x11-misc
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-17b5c22dc3dd90ebfbda5ba83e3f9c8b82adf698.tar.gz
gentoo-2-17b5c22dc3dd90ebfbda5ba83e3f9c8b82adf698.tar.bz2
gentoo-2-17b5c22dc3dd90ebfbda5ba83e3f9c8b82adf698.zip
cleaned up ebuild stuff to be compliant with current policies
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/tkhylafax/ChangeLog8
-rw-r--r--x11-misc/tkhylafax/metadata.xml14
-rw-r--r--x11-misc/tkhylafax/tkhylafax-3.2.ebuild20
3 files changed, 21 insertions, 21 deletions
diff --git a/x11-misc/tkhylafax/ChangeLog b/x11-misc/tkhylafax/ChangeLog
index 659f99a67ee1..dd855e0d6720 100644
--- a/x11-misc/tkhylafax/ChangeLog
+++ b/x11-misc/tkhylafax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/tkhylafax
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tkhylafax/ChangeLog,v 1.1 2003/09/24 02:54:16 nerdboy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tkhylafax/ChangeLog,v 1.2 2004/04/26 03:05:46 nerdboy Exp $
+
+ 25 Apr 2004; Steve Arnold <nerdboy@gentoo.org> metadata.xml,
+ tkhylafax-3.2.ebuild:
+ fixed minor ebuild glitches
*tkhylafax-3.2 (23 Sep 2003)
diff --git a/x11-misc/tkhylafax/metadata.xml b/x11-misc/tkhylafax/metadata.xml
index 9827a6d93286..85eed07d0c6f 100644
--- a/x11-misc/tkhylafax/metadata.xml
+++ b/x11-misc/tkhylafax/metadata.xml
@@ -7,15 +7,9 @@
<name>Steve Arnold</name>
<description>Primary Maintainer</description>
</maintainer>
-<longdescription>Front end for sending faxes with HylaFAX. Current features include:
- o Batching fax destinations
- o Built-in faxnumber database
- o Fast cover sheet generation
- o Cover sheet preview
- o Cover sheet ONLY transmission option
- o Directory browser
- o Fax job dequeuing made easier
- o Fax job scheduling made easier
- o Highly configurable
+<longdescription>Front end for sending faxes with HylaFAX.
+This code has barely been touched in several years, but it
+works well enough, and is the only *nix client I found that
+has certain features...
</longdescription>
</pkgmetadata>
diff --git a/x11-misc/tkhylafax/tkhylafax-3.2.ebuild b/x11-misc/tkhylafax/tkhylafax-3.2.ebuild
index 5a9e782b4202..bdb9dd750848 100644
--- a/x11-misc/tkhylafax/tkhylafax-3.2.ebuild
+++ b/x11-misc/tkhylafax/tkhylafax-3.2.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tkhylafax/tkhylafax-3.2.ebuild,v 1.3 2004/02/17 08:03:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tkhylafax/tkhylafax-3.2.ebuild,v 1.4 2004/04/26 03:05:46 nerdboy Exp $
# This is a new ebuild for the tkHylafax client. This code has barely been
# touched in several years, but it works well enough, and is the only
# *nix client I found that has certain features...
-IUSE="tcltk"
+inherit eutils
+
+IUSE=""
-S=${WORKDIR}/${P}
DESCRIPTION="Tk-based client for HylaFAX(tm) with rolodex and batch faxing support."
HOMEPAGE="http://www.hylafax.org"
SRC_URI="ftp://ftp.hylafax.org/contrib/tkhylafax/${P}.tar.gz"
SLOT="0"
LICENSE="freedist"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
+KEYWORDS="x86 sparc"
-DEPEND="dev-lang/tk"
+DEPEND="dev-lang/tk
+ net-misc/hylafax"
RDEPEND="${DEPEND}
app-text/gv"
@@ -25,7 +27,7 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
cd ${WORKDIR}/${P}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.patch
+ epatch ${FILESDIR}/${PF}-gentoo.patch
}
src_compile() {
@@ -50,7 +52,7 @@ pkg_postinst() {
einfo "This package requires a HylaFAX(tm) server somewhere on your"
einfo "network (it can also be on the same machine) in order to be"
- einfo "useful. Read the tkhylafax man page for important tips on"
- einfo "configuring the proper environment variables for the batch"
- einfo "and rolodex data."
+ einfo "useful. You also need the hylafax client command 'sendfax'"
+ einfo "Read the tkhylafax man page for important tips on configuring"
+ einfo "the proper environment variables for the batch and rolodex data."
}