summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2010-09-12 11:12:04 +0000
committerChristian Birchinger <joker@gentoo.org>2010-09-12 11:12:04 +0000
commit104008c91a20ac59c5c971c6ce4f16346609fa68 (patch)
tree526015892f476e55ba31494d1604f62016303f4a /x11-misc
parentRemove KDE 4.5.1 mask from profiles/package.mask, it is now in base/package.m... (diff)
downloadgentoo-2-104008c91a20ac59c5c971c6ce4f16346609fa68.tar.gz
gentoo-2-104008c91a20ac59c5c971c6ce4f16346609fa68.tar.bz2
gentoo-2-104008c91a20ac59c5c971c6ce4f16346609fa68.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdotool/ChangeLog8
-rw-r--r--x11-misc/xdotool/xdotool-2.20100818.3004.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
index 6beae9b8ca6e..86c0dfe2b5e4 100644
--- a/x11-misc/xdotool/ChangeLog
+++ b/x11-misc/xdotool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xdotool
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.11 2010/05/23 20:01:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.12 2010/09/12 11:12:04 joker Exp $
+
+*xdotool-2.20100818.3004 (12 Sep 2010)
+
+ 12 Sep 2010; Christian Birchinger <joker@gentoo.org>
+ +xdotool-2.20100818.3004.ebuild:
+ Version bump
23 May 2010; Pacho Ramos <pacho@gentoo.org> xdotool-20091231.02.ebuild:
stable amd64, bug 312729
diff --git a/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild b/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild
new file mode 100644
index 000000000000..204c64262e27
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild,v 1.1 2010/09/12 11:12:04 joker Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND="x11-libs/libXtst
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}"
+
+# The test wants to manualy start Xvfb, wont use VirtualX and it tries
+# to run a full gnome-session. For such a tiny application i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC LD
+ export LDFLAGS="$(raw-ldflags)"
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}