summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-02-19 11:51:54 +0000
committerVlastimil Babka <caster@gentoo.org>2010-02-19 11:51:54 +0000
commit0acc9164c41ec0b744d1ebaee3d254c837585469 (patch)
tree7b37bf4f9f71852dd3e672479c26f20f36680a5a /x11-misc
parentVersion bump (diff)
downloadgentoo-2-0acc9164c41ec0b744d1ebaee3d254c837585469.tar.gz
gentoo-2-0acc9164c41ec0b744d1ebaee3d254c837585469.tar.bz2
gentoo-2-0acc9164c41ec0b744d1ebaee3d254c837585469.zip
Fix bug #303789 properly by depending on a fixed version of emul qtlibs.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/googleearth/ChangeLog7
-rw-r--r--x11-misc/googleearth/googleearth-5.1.3509.4636_beta.ebuild119
-rw-r--r--x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild7
-rw-r--r--x11-misc/googleearth/googleearth-5.1.3533.1731.ebuild119
4 files changed, 8 insertions, 244 deletions
diff --git a/x11-misc/googleearth/ChangeLog b/x11-misc/googleearth/ChangeLog
index aed289f334e3..f555bba2aeb2 100644
--- a/x11-misc/googleearth/ChangeLog
+++ b/x11-misc/googleearth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/googleearth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.56 2010/02/19 08:51:53 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/ChangeLog,v 1.57 2010/02/19 11:51:54 caster Exp $
+
+ 19 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.1.3509.4636_beta.ebuild, -googleearth-5.1.3533.1731.ebuild,
+ googleearth-5.1.3533.1731-r1.ebuild:
+ Fix bug #303789 properly by depending on a fixed version of emul qtlibs.
19 Feb 2010; Vlastimil Babka <caster@gentoo.org>
googleearth-5.1.3533.1731-r1.ebuild:
diff --git a/x11-misc/googleearth/googleearth-5.1.3509.4636_beta.ebuild b/x11-misc/googleearth/googleearth-5.1.3509.4636_beta.ebuild
deleted file mode 100644
index 57da276762c8..000000000000
--- a/x11-misc/googleearth/googleearth-5.1.3509.4636_beta.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-5.1.3509.4636_beta.ebuild,v 1.3 2010/02/11 15:47:30 ulm Exp $
-
-EAPI=2
-
-inherit eutils fdo-mime versionator toolchain-funcs
-
-DESCRIPTION="A 3D interface to the planet"
-HOMEPAGE="http://earth.google.com/"
-# no upstream versioning, version determined from help/about
-# incorrect digest means upstream bumped and thus needs version bump
-SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin
- -> GoogleEarthLinux-${PV}.bin"
-
-LICENSE="googleearth MIT SGI-B-1.1 openssl as-is ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror strip"
-IUSE=""
-
-GCC_NEEDED="4.2"
-
-RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
- x86? (
- media-libs/fontconfig
- media-libs/freetype
- virtual/opengl
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXau
- x11-libs/libXdmcp
- sys-libs/zlib
- dev-libs/glib:2
- )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-baselibs
- || (
- >=app-emulation/emul-linux-x86-xlibs-7.0
- x11-drivers/nvidia-drivers
- <x11-drivers/ati-drivers-8.28.8
- )
- )
- media-fonts/ttf-bitstream-vera"
-
-S="${WORKDIR}"
-
-QA_TEXTRELS="opt/googleearth/libgps.so
-opt/googleearth/libgooglesearch.so
-opt/googleearth/libevll.so
-opt/googleearth/librender.so
-opt/googleearth/libinput_plugin.so
-opt/googleearth/libflightsim.so
-opt/googleearth/libcollada.so
-opt/googleearth/libminizip.so
-opt/googleearth/libauth.so
-opt/googleearth/libbasicingest.so
-opt/googleearth/libmeasure.so
-opt/googleearth/libgoogleearth_lib.so
-opt/googleearth/libmoduleframework.so
-"
-
-QA_DT_HASH="opt/${PN}/.*"
-
-pkg_setup() {
- GCC_VER="$(gcc-version)"
- if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
- ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
- ewarn "Your active gcc version is only ${GCC_VER}"
- ewarn "Please consult the GCC upgrade guide to set a higher version:"
- ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
- fi
-}
-
-src_unpack() {
- unpack_makeself
-}
-
-src_prepare() {
- # make the postinst script only create the files; it's installation
- # are too complicated and inserting them ourselves is easier than
- # hacking around it
- sed -i -e 's:$SETUP_INSTALLPATH/::' \
- -e 's:$SETUP_INSTALLPATH:1:' \
- -e "s:^xdg-desktop-icon.*$::" \
- -e "s:^xdg-desktop-menu.*$::" \
- -e "s:^xdg-mime.*$::" postinstall.sh
-}
-
-src_install() {
- make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
- ./postinstall.sh
- insinto /usr/share/mime/packages
- doins ${PN}-mimetypes.xml
- domenu Google-${PN}.desktop
- doicon ${PN}-icon.png
- dodoc README.linux
-
- cd bin
- tar xf "${WORKDIR}"/${PN}-linux-x86.tar
- exeinto /opt/${PN}
- doexe *
-
- cd "${D}"/opt/${PN}
- tar xf "${WORKDIR}"/${PN}-data.tar
-
- fowners -R root:root /opt/${PN}
- fperms -R a-x,a+X /opt/googleearth/{xml,resources}
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}
diff --git a/x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild b/x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild
index 0424e4fadb01..db71ee65f485 100644
--- a/x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild
+++ b/x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild,v 1.5 2010/02/19 08:51:53 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-5.1.3533.1731-r1.ebuild,v 1.6 2010/02/19 11:51:54 caster Exp $
EAPI=2
@@ -21,8 +21,6 @@ IUSE="qt-bundled"
GCC_NEEDED="4.2"
-# the 64bit qt-core is needed to put the emul package on LDPATH
-# - workaround for bug #303789
RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
x86? (
media-libs/fontconfig
@@ -48,8 +46,7 @@ RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
>=app-emulation/emul-linux-x86-xlibs-20081109
>=app-emulation/emul-linux-x86-baselibs-20081109
!qt-bundled? (
- x11-libs/qt-core
- >=app-emulation/emul-linux-x86-qtlibs-20091231
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
)
)
|| (
diff --git a/x11-misc/googleearth/googleearth-5.1.3533.1731.ebuild b/x11-misc/googleearth/googleearth-5.1.3533.1731.ebuild
deleted file mode 100644
index 5c2e77d2b7a1..000000000000
--- a/x11-misc/googleearth/googleearth-5.1.3533.1731.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/googleearth/googleearth-5.1.3533.1731.ebuild,v 1.2 2010/02/11 15:47:30 ulm Exp $
-
-EAPI=2
-
-inherit eutils fdo-mime versionator toolchain-funcs
-
-DESCRIPTION="A 3D interface to the planet"
-HOMEPAGE="http://earth.google.com/"
-# no upstream versioning, version determined from help/about
-# incorrect digest means upstream bumped and thus needs version bump
-SRC_URI="http://dl.google.com/earth/client/current/GoogleEarthLinux.bin
- -> GoogleEarthLinux-${PV}.bin"
-
-LICENSE="googleearth MIT SGI-B-1.1 openssl as-is ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror strip"
-IUSE=""
-
-GCC_NEEDED="4.2"
-
-RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
- x86? (
- media-libs/fontconfig
- media-libs/freetype
- virtual/opengl
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXau
- x11-libs/libXdmcp
- sys-libs/zlib
- dev-libs/glib:2
- )
- amd64? (
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-baselibs
- || (
- >=app-emulation/emul-linux-x86-xlibs-7.0
- x11-drivers/nvidia-drivers
- <x11-drivers/ati-drivers-8.28.8
- )
- )
- media-fonts/ttf-bitstream-vera"
-
-S="${WORKDIR}"
-
-QA_TEXTRELS="opt/googleearth/libgps.so
-opt/googleearth/libgooglesearch.so
-opt/googleearth/libevll.so
-opt/googleearth/librender.so
-opt/googleearth/libinput_plugin.so
-opt/googleearth/libflightsim.so
-opt/googleearth/libcollada.so
-opt/googleearth/libminizip.so
-opt/googleearth/libauth.so
-opt/googleearth/libbasicingest.so
-opt/googleearth/libmeasure.so
-opt/googleearth/libgoogleearth_lib.so
-opt/googleearth/libmoduleframework.so
-"
-
-QA_DT_HASH="opt/${PN}/.*"
-
-pkg_setup() {
- GCC_VER="$(gcc-version)"
- if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
- ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
- ewarn "Your active gcc version is only ${GCC_VER}"
- ewarn "Please consult the GCC upgrade guide to set a higher version:"
- ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
- fi
-}
-
-src_unpack() {
- unpack_makeself
-}
-
-src_prepare() {
- # make the postinst script only create the files; it's installation
- # are too complicated and inserting them ourselves is easier than
- # hacking around it
- sed -i -e 's:$SETUP_INSTALLPATH/::' \
- -e 's:$SETUP_INSTALLPATH:1:' \
- -e "s:^xdg-desktop-icon.*$::" \
- -e "s:^xdg-desktop-menu.*$::" \
- -e "s:^xdg-mime.*$::" postinstall.sh
-}
-
-src_install() {
- make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
- ./postinstall.sh
- insinto /usr/share/mime/packages
- doins ${PN}-mimetypes.xml
- domenu Google-${PN}.desktop
- doicon ${PN}-icon.png
- dodoc README.linux
-
- cd bin
- tar xf "${WORKDIR}"/${PN}-linux-x86.tar
- exeinto /opt/${PN}
- doexe *
-
- cd "${D}"/opt/${PN}
- tar xf "${WORKDIR}"/${PN}-data.tar
-
- fowners -R root:root /opt/${PN}
- fperms -R a-x,a+X /opt/googleearth/resources
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}