summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-03 00:55:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-03 00:55:17 +0000
commit5343e7fe300ff7c6475d3b077e9f3483cc32df23 (patch)
treee06ad6668c572505d100f6bafbbafc77daade057 /x11-misc/xwit
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-5343e7fe300ff7c6475d3b077e9f3483cc32df23.tar.gz
gentoo-2-5343e7fe300ff7c6475d3b077e9f3483cc32df23.tar.bz2
gentoo-2-5343e7fe300ff7c6475d3b077e9f3483cc32df23.zip
Use small Makefile instead of obsolete X11R6 imake.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xwit')
-rw-r--r--x11-misc/xwit/ChangeLog8
-rw-r--r--x11-misc/xwit/files/Makefile10
-rw-r--r--x11-misc/xwit/xwit-3.4.ebuild29
3 files changed, 31 insertions, 16 deletions
diff --git a/x11-misc/xwit/ChangeLog b/x11-misc/xwit/ChangeLog
index 1965647487b1..b655b7c9b671 100644
--- a/x11-misc/xwit/ChangeLog
+++ b/x11-misc/xwit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xwit
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/ChangeLog,v 1.9 2007/02/22 00:13:05 jokey Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/ChangeLog,v 1.10 2010/04/03 00:55:17 ssuominen Exp $
+
+ 03 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> xwit-3.4.ebuild,
+ +files/Makefile:
+ Use small Makefile instead of obsolete X11R6 imake.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-misc/xwit/files/Makefile b/x11-misc/xwit/files/Makefile
new file mode 100644
index 000000000000..d16ec11641a6
--- /dev/null
+++ b/x11-misc/xwit/files/Makefile
@@ -0,0 +1,10 @@
+src = xwit.c dsimple.c ClientWin.c
+o = $(addsuffix .o,$(basename ${src}))
+
+all: xwit
+
+%.o: %.cpp
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+xwit: $(o)
+ $(CC) $(LDFLAGS) $(o) -o xwit -lX11
diff --git a/x11-misc/xwit/xwit-3.4.ebuild b/x11-misc/xwit/xwit-3.4.ebuild
index 69a9118be31a..0051b33ba370 100644
--- a/x11-misc/xwit/xwit-3.4.ebuild
+++ b/x11-misc/xwit/xwit-3.4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/xwit-3.4.ebuild,v 1.9 2006/10/22 01:43:00 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/xwit-3.4.ebuild,v 1.10 2010/04/03 00:55:17 ssuominen Exp $
-inherit eutils
+EAPI=2
+inherit eutils toolchain-funcs
-DESCRIPTION="xwit (x window interface tool) is a hodge-podge collection of simple routines to call some of those X11 functions that don't already have any utility commands built around them."
+DESCRIPTION="A collection of simple routines to call some of those X11 functions"
HOMEPAGE="http://ftp.x.org/contrib/utilities/xwit-3.4.README"
SRC_URI="http://ftp.x.org/contrib/utilities/${P}.tar.gz"
@@ -13,21 +14,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-RDEPEND="x11-libs/libX11
- x11-libs/libXext"
+RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
- x11-misc/imake
x11-proto/xproto"
-src_compile() {
- epatch "${FILESDIR}/malloc.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/malloc.patch
+ cp -vf "${FILESDIR}"/Makefile .
+}
- xmkmf || die "xmkmf failed"
- emake || die "Make failed"
+src_compile() {
+ tc-export CC
+ emake || die
}
src_install() {
- dobin xwit
- cp xwit.man xwit.1
- doman xwit.1
+ dobin xwit || die
+ newman xwit.man xwit.1 || die
}