summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-15 19:01:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-15 19:01:10 +0000
commitb0ae9366944409e890fe932ea8589a4052c0daa7 (patch)
treeed132fa4420b3f1e03a9af34da04e6ba162d7e86 /x11-misc/xsimpsons
parentVersion bump, and pulseaudio plugins are now in gst-plugins-good, fixes bug #... (diff)
downloadgentoo-2-b0ae9366944409e890fe932ea8589a4052c0daa7.tar.gz
gentoo-2-b0ae9366944409e890fe932ea8589a4052c0daa7.tar.bz2
gentoo-2-b0ae9366944409e890fe932ea8589a4052c0daa7.zip
Add new revision respecting CFLAGS and LDFLAGS properly (rewriting the Makefile).
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'x11-misc/xsimpsons')
-rw-r--r--x11-misc/xsimpsons/ChangeLog9
-rw-r--r--x11-misc/xsimpsons/xsimpsons-0.1-r1.ebuild41
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-misc/xsimpsons/ChangeLog b/x11-misc/xsimpsons/ChangeLog
index c3cb93d6d6ef..6d6e3219e750 100644
--- a/x11-misc/xsimpsons/ChangeLog
+++ b/x11-misc/xsimpsons/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xsimpsons
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsimpsons/ChangeLog,v 1.15 2008/05/31 23:06:49 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsimpsons/ChangeLog,v 1.16 2008/10/15 19:01:10 flameeyes Exp $
+
+*xsimpsons-0.1-r1 (15 Oct 2008)
+
+ 15 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +xsimpsons-0.1-r1.ebuild:
+ Add new revision respecting CFLAGS and LDFLAGS properly (rewriting the
+ Makefile).
31 May 2008; Santiago M. Mola <coldwind@gentoo.org> xsimpsons-0.1.ebuild:
amd64 stable and install docs
diff --git a/x11-misc/xsimpsons/xsimpsons-0.1-r1.ebuild b/x11-misc/xsimpsons/xsimpsons-0.1-r1.ebuild
new file mode 100644
index 000000000000..3dbfbb7b0d2f
--- /dev/null
+++ b/x11-misc/xsimpsons/xsimpsons-0.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsimpsons/xsimpsons-0.1-r1.ebuild,v 1.1 2008/10/15 19:01:10 flameeyes Exp $
+inherit toolchain-funcs
+
+DESCRIPTION="The Simpsons walking along the tops of your windows."
+HOMEPAGE="http://netzverschmutzer.net/~sbeyer/programming/projects/?dir=extensions#xpenguins"
+SRC_URI="http://netzverschmutzer.net/~sbeyer/programming/projects/extensions/xpenguins/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Replace Makefile, easier than patching it out!
+ cat - > Makefile <<EOF
+${PN}: xsimpsons.o toon.o
+ \$(CC) \$(LDFLAGS) -o \$@ \$^ -lX11 -lXpm -lXext
+EOF
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin xsimpsons || die "dobin failed"
+ dodoc AUTHORS README
+}