summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-05 21:59:55 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-05 21:59:55 +0000
commit2ec5ddbddbb462fca8d2a07d203b572e3aff1b81 (patch)
tree8dd1084ef6f205c9794861e6fb5bfdf5da508b3e /x11-misc/xscreensaver
parentRevert previous additions which duplicate rev bumps (diff)
downloadgentoo-2-2ec5ddbddbb462fca8d2a07d203b572e3aff1b81.tar.gz
gentoo-2-2ec5ddbddbb462fca8d2a07d203b572e3aff1b81.tar.bz2
gentoo-2-2ec5ddbddbb462fca8d2a07d203b572e3aff1b81.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xscreensaver')
-rw-r--r--x11-misc/xscreensaver/ChangeLog8
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch21
-rw-r--r--x11-misc/xscreensaver/xscreensaver-5.28.ebuild138
3 files changed, 166 insertions, 1 deletions
diff --git a/x11-misc/xscreensaver/ChangeLog b/x11-misc/xscreensaver/ChangeLog
index 49fef4d5bd19..1f834ba2d25c 100644
--- a/x11-misc/xscreensaver/ChangeLog
+++ b/x11-misc/xscreensaver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xscreensaver
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xscreensaver/ChangeLog,v 1.356 2014/06/04 12:25:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xscreensaver/ChangeLog,v 1.357 2014/06/05 21:59:55 jer Exp $
+
+*xscreensaver-5.28 (05 Jun 2014)
+
+ 05 Jun 2014; Jeroen Roovers <jer@gentoo.org> +xscreensaver-5.28.ebuild,
+ +files/xscreensaver-5.28-comment-style.patch:
+ Version bump.
04 Jun 2014; Jeroen Roovers <jer@gentoo.org> xscreensaver-5.27.ebuild:
die().
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch b/x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch
new file mode 100644
index 000000000000..6c3143d758b7
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.28-comment-style.patch
@@ -0,0 +1,21 @@
+--- a/hacks/tessellimage.c
++++ b/hacks/tessellimage.c
+@@ -507,15 +507,15 @@
+ out[i].p = (n > 0
+ ? (XPoint *) calloc (out[i].npoints + 1, sizeof (*out[i].p))
+ : 0);
+-//printf("%d: ", i);
++/*printf("%d: ", i);*/
+ for (j = 0; j < out[i].npoints; j++)
+ {
+ ITRIANGLE *tt = &v[t->tri[j]];
+ out[i].p[j].x = (p[tt->p1].x + p[tt->p2].x + p[tt->p3].x) / 3;
+ out[i].p[j].y = (p[tt->p1].y + p[tt->p2].y + p[tt->p3].y) / 3;
+-//printf(" [%d: %d %d]", j, out[i].p[j].x, out[i].p[j].y);
++/*printf(" [%d: %d %d]", j, out[i].p[j].x, out[i].p[j].y);*/
+ }
+-//printf("\n");
++/*printf("\n");*/
+ }
+
+ free (vert_to_tri);
diff --git a/x11-misc/xscreensaver/xscreensaver-5.28.ebuild b/x11-misc/xscreensaver/xscreensaver-5.28.ebuild
new file mode 100644
index 000000000000..e0cc8f55abb6
--- /dev/null
+++ b/x11-misc/xscreensaver/xscreensaver-5.28.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xscreensaver/xscreensaver-5.28.ebuild,v 1.1 2014/06/05 21:59:55 jer Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib pam
+
+DESCRIPTION="A modular screen saver and locker for the X Window System"
+HOMEPAGE="http://www.jwz.org/xscreensaver/"
+SRC_URI="http://www.jwz.org/xscreensaver/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="gdm jpeg new-login opengl pam +perl selinux suid xinerama"
+
+COMMON_DEPEND="dev-libs/libxml2
+ >=gnome-base/libglade-2
+ media-libs/netpbm
+ x11-apps/appres
+ x11-apps/xwininfo
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXrandr
+ x11-libs/libXt
+ x11-libs/libXxf86misc
+ x11-libs/libXxf86vm
+ jpeg? ( virtual/jpeg:0 )
+ new-login? (
+ gdm? ( gnome-base/gdm )
+ !gdm? ( || ( x11-misc/lightdm kde-base/kdm ) )
+ )
+ opengl? ( virtual/opengl )
+ pam? ( virtual/pam )
+ selinux? ( sec-policy/selinux-xscreensaver )
+ xinerama? ( x11-libs/libXinerama )"
+# For USE="perl" see output of `qlist xscreensaver | grep bin | xargs grep '::'`
+RDEPEND="${COMMON_DEPEND}
+ perl? (
+ dev-lang/perl
+ dev-perl/libwww-perl
+ virtual/perl-Digest-MD5
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/bc
+ sys-devel/gettext
+ x11-proto/recordproto
+ x11-proto/scrnsaverproto
+ x11-proto/xextproto
+ x11-proto/xf86miscproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_prepare() {
+ sed -i configure.in -e '/^ALL_LINGUAS=/d' || die
+ strip-linguas -i po/
+ export ALL_LINGUAS="${LINGUAS}"
+
+ if use new-login && ! use gdm; then #392967
+ sed -i \
+ -e "/default_l.*1/s:gdmflexiserver -ls:${EPREFIX}/usr/libexec/lightdm/&:" \
+ configure{,.in} || die
+ fi
+
+ epatch \
+ "${FILESDIR}"/${PN}-5.21-gentoo.patch \
+ "${FILESDIR}"/${PN}-5.05-interix.patch \
+ "${FILESDIR}"/${PN}-5.20-blurb-hndl-test-passwd.patch \
+ "${FILESDIR}"/${PN}-5.20-test-passwd-segv-tty.patch \
+ "${FILESDIR}"/${PN}-5.20-tests-miscfix.patch \
+ "${FILESDIR}"/${PN}-5.28-comment-style.patch
+
+ eautoconf
+ eautoheader
+}
+
+src_configure() {
+ if use ppc || use ppc64; then
+ filter-flags -maltivec -mabi=altivec
+ append-flags -U__VEC__
+ fi
+
+ unset BC_ENV_ARGS #24568
+ export RPM_PACKAGE_VERSION=no #368025
+
+ append-libs -lpthread
+
+ econf \
+ $(use_with jpeg) \
+ $(use_with new-login login-manager) \
+ $(use_with opengl gl) \
+ $(use_with pam) \
+ $(use_with suid setuid-hacks) \
+ $(use_with xinerama xinerama-ext) \
+ --enable-locking \
+ --with-configdir="${EPREFIX}"/usr/share/${PN}/config \
+ --with-dpms-ext \
+ --with-gtk \
+ --with-hackdir="${EPREFIX}"/usr/$(get_libdir)/misc/${PN} \
+ --with-pixbuf \
+ --with-proc-interrupts \
+ --with-randr-ext \
+ --with-text-file="${EPREFIX}"/etc/gentoo-release \
+ --with-x-app-defaults="${EPREFIX}"/usr/share/X11/app-defaults \
+ --with-xdbe-ext \
+ --with-xf86gamma-ext \
+ --with-xf86vmode-ext \
+ --with-xinput-ext \
+ --with-xshm-ext \
+ --without-gle \
+ --without-kerberos \
+ --x-includes="${EPREFIX}"/usr/include \
+ --x-libraries="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_compile() {
+ default
+
+ intltool-merge po/ -d -u \
+ driver/screensaver-properties.desktop.in \
+ driver/screensaver-properties.desktop || die
+}
+
+src_install() {
+ emake install_prefix="${D}" install
+
+ dodoc README{,.hacking}
+
+ use pam && fperms 755 /usr/bin/${PN}
+ pamd_mimic_system ${PN} auth
+
+ rm -f "${ED}"/usr/share/${PN}/config/{electricsheep,fireflies}.xml
+}