summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-03-06 02:31:44 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-03-06 02:31:44 +0000
commit0c743bc87d0a1e8cc55c4c2770fb23a6db222575 (patch)
treebd4a32f011387a4ad1d753e59d167e1e5eaccaf9 /x11-misc/xrmap
parentAdded sed to fix DPATH and SPATH. (diff)
downloadgentoo-2-0c743bc87d0a1e8cc55c4c2770fb23a6db222575.tar.gz
gentoo-2-0c743bc87d0a1e8cc55c4c2770fb23a6db222575.tar.bz2
gentoo-2-0c743bc87d0a1e8cc55c4c2770fb23a6db222575.zip
Initial import.
Diffstat (limited to 'x11-misc/xrmap')
-rw-r--r--x11-misc/xrmap/ChangeLog9
-rw-r--r--x11-misc/xrmap/Manifest2
-rw-r--r--x11-misc/xrmap/files/digest-xrmap-2.102
-rw-r--r--x11-misc/xrmap/xrmap-2.10.ebuild49
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/xrmap/ChangeLog b/x11-misc/xrmap/ChangeLog
new file mode 100644
index 000000000000..d95cd51ba37f
--- /dev/null
+++ b/x11-misc/xrmap/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/xrmap
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/ChangeLog,v 1.1 2004/03/06 02:31:44 pyrania Exp $
+
+*xrmap-2.10 (06 Mar 2004)
+
+ 06 Mar 2004; Markus Nigbur <pyrania@gentoo.org> xrmap-2.10.ebuild:
+ Initial import.
+
diff --git a/x11-misc/xrmap/Manifest b/x11-misc/xrmap/Manifest
new file mode 100644
index 000000000000..cfae7339a760
--- /dev/null
+++ b/x11-misc/xrmap/Manifest
@@ -0,0 +1,2 @@
+MD5 6a62d03e288c2bc0c44dd0e4f86a6fa6 xrmap-2.10.ebuild 1656
+MD5 d3d071db1ec04cf25a797313b25b8f49 files/digest-xrmap-2.10 121
diff --git a/x11-misc/xrmap/files/digest-xrmap-2.10 b/x11-misc/xrmap/files/digest-xrmap-2.10
new file mode 100644
index 000000000000..34a01b3f8ea2
--- /dev/null
+++ b/x11-misc/xrmap/files/digest-xrmap-2.10
@@ -0,0 +1,2 @@
+MD5 e18247abf044e8e00616ef67f6126678 xrmap-2.10.tgz 3944521
+MD5 534818ffb498322b64373f66ae042596 CIA_WDB2.jpd.gz 7391060
diff --git a/x11-misc/xrmap/xrmap-2.10.ebuild b/x11-misc/xrmap/xrmap-2.10.ebuild
new file mode 100644
index 000000000000..a49c30ee5ca2
--- /dev/null
+++ b/x11-misc/xrmap/xrmap-2.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.10.ebuild,v 1.1 2004/03/06 02:31:44 pyrania Exp $
+
+DESCRIPTION="The Xrmap program is a X client for generating images of the Earth and manipulating the CIA World data bank"
+HOMEPAGE="http://frmas.free.fr/li_1.htm#_Xrmap_"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${P}.tgz
+ ftp://ftp.ac-grenoble.fr/ge/geosciences/CIA_WDB2.jpd.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="zlib"
+DEPEND="media-gfx/imagemagick
+ app-text/gv
+ sys-apps/less
+ media-libs/xpm
+ >=sys-apps/sed-4
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ use zlib || sed -i 's/-DZLIB\|-lz//g' Makefile.noimake || die
+
+ sed -e 's,^\(X11DIR=\).*,\1/usr/,g' \
+ -e 's,^\(EDITOR=\).*,\1less,g' \
+ -e 's,^\(SHAREDIR=\).*,\1/usr/share/xrmap,g' \
+ -e 's,^\(CCOPTIONS=\)-O6 -g,\1${CFLAGS},g' Makefile.noimake > Makefile || die
+
+ sed -i -e 's,^\(#define RCFILE \)SHAREDIR\",\1\"/etc/xrmap,g' \
+ -e 's,^\(#define SHAREDIR \"/usr/share/\),\1x,g' xrmap.h || die
+ emake || die
+ cd tools
+ emake || die
+ cd jpd2else
+ sed -i 's,^\(#define DEFAULT_JPD_FILE \"/usr/share/\),\1x,g' jpd2else.c || die
+ emake || die
+ cd ../cbd2else
+ emake || die
+}
+
+src_install() {
+ dobin xrmap tools/preproc tools/jpd2else/jpd2else tools/cbd2else/cbd2else || die
+ dodir /usr/share/${PN}/ || die
+ dodir /etc/xrmap || die
+ cp -r {i18n,Locations,factbook,anthems,flags} ${D}/usr/share/${PN}/ || die
+ cp Xrmaprc ${D}/etc/xrmap || die
+ cp ${WORKDIR}/CIA_WDB2.jpd ${D}/usr/share/${PN}/ || die
+ dodoc CHANGES COPYING README TODO WARNING tools/cbd2else/README.cbd tools/jpd2else/README.jpd tools/rez2else/README.rez || die
+}