summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-07-03 15:40:05 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-07-03 15:40:05 +0000
commit6c7f5852feaeafc6e0ca16b5a3f1fdcadd751d22 (patch)
tree840eff0d42d7c9f8fec5ebb69bb37608b08b80d8 /x11-misc/xrmap/xrmap-2.29.ebuild
parentFix compilation in src_install (Manifest recommit) (diff)
downloadgentoo-2-6c7f5852feaeafc6e0ca16b5a3f1fdcadd751d22.tar.gz
gentoo-2-6c7f5852feaeafc6e0ca16b5a3f1fdcadd751d22.tar.bz2
gentoo-2-6c7f5852feaeafc6e0ca16b5a3f1fdcadd751d22.zip
Version bump. Closing bug #47525.
Diffstat (limited to 'x11-misc/xrmap/xrmap-2.29.ebuild')
-rw-r--r--x11-misc/xrmap/xrmap-2.29.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/xrmap/xrmap-2.29.ebuild b/x11-misc/xrmap/xrmap-2.29.ebuild
new file mode 100644
index 000000000000..932a3420f4e8
--- /dev/null
+++ b/x11-misc/xrmap/xrmap-2.29.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.29.ebuild,v 1.1 2004/07/03 15:40:05 pyrania Exp $
+
+DESCRIPTION="The Xrmap program is a X client for generating images of the Earth and manipulating the CIA World data bank"
+HOMEPAGE="http://frmas.free.fr/li_1.htm#_Xrmap_"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${P}.tar.bz2
+ ftp://ftp.ac-grenoble.fr/ge/geosciences/CIA_WDB2.jpd.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="zlib"
+DEPEND="media-gfx/imagemagick
+ app-text/gv
+ sys-apps/less
+ media-libs/xpm
+ >=sys-apps/sed-4
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ use zlib || sed -i 's/-DZLIB\|-lz//g' Makefile.noimake || die
+
+ sed -e 's,^\(X11DIR=\).*,\1/usr/,g' \
+ -e 's,^\(EDITOR=\).*,\1less,g' \
+ -e 's,^\(SHAREDIR=\).*,\1/usr/share/xrmap,g' \
+ -e 's,^\(CCOPTIONS=\)-O6 -g,\1${CFLAGS},g' Makefile.noimake > Makefile || die
+
+ sed -i -e 's,^\(#define RCFILE \)SHAREDIR\",\1\"/etc/xrmap,g' \
+ -e 's,^\(#define SHAREDIR \"/usr/share/\),\1x,g' xrmap.h || die
+ emake || die
+ cd tools
+ emake || die
+ cd jpd2else
+ sed -i 's,^\(#define DEFAULT_JPD_FILE \"/usr/share/\),\1x,g' jpd2else.c || die
+ emake || die
+ cd ../cbd2else
+ emake || die
+}
+
+src_install() {
+ dobin xrmap tools/preproc tools/jpd2else/jpd2else tools/cbd2else/cbd2else || die
+ dodir /usr/share/${PN}/ || die
+ dodir /etc/xrmap || die
+ cp -r {i18n,Locations,factbook,anthems,flags,hymns} ${D}/usr/share/${PN}/ || die
+ cp Xrmaprc ${D}/etc/xrmap || die
+ cp ${WORKDIR}/CIA_WDB2.jpd ${D}/usr/share/${PN}/ || die
+ dodoc CHANGES COPYING README TODO WARNING tools/cbd2else/README.cbd tools/jpd2else/README.jpd tools/rez2else/README.rez || die
+
+ cd ${S}
+ newman xrmap.man xrmap.1 || die "newman failed"
+}