summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-08-27 10:55:25 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-08-27 10:55:25 +0000
commit28284bb232c55a8b8ed258cf670f64aa86a64714 (patch)
treea0bdc63736146a4722ea06ea048a30465d83d103 /x11-misc/xrmap/xrmap-2.29.ebuild
parentSee bug 61131 (Manifest recommit) (diff)
downloadgentoo-2-28284bb232c55a8b8ed258cf670f64aa86a64714.tar.gz
gentoo-2-28284bb232c55a8b8ed258cf670f64aa86a64714.tar.bz2
gentoo-2-28284bb232c55a8b8ed258cf670f64aa86a64714.zip
Fixing bug #56225. Thanks to James Leddy and Alexandre Veyrenc.
Diffstat (limited to 'x11-misc/xrmap/xrmap-2.29.ebuild')
-rw-r--r--x11-misc/xrmap/xrmap-2.29.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/x11-misc/xrmap/xrmap-2.29.ebuild b/x11-misc/xrmap/xrmap-2.29.ebuild
index 4452337b29ed..6006402aab9c 100644
--- a/x11-misc/xrmap/xrmap-2.29.ebuild
+++ b/x11-misc/xrmap/xrmap-2.29.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.29.ebuild,v 1.2 2004/08/14 14:57:28 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.29.ebuild,v 1.3 2004/08/27 10:55:25 pyrania Exp $
DESCRIPTION="The Xrmap program is a X client for generating images of the Earth and manipulating the CIA World data bank"
HOMEPAGE="http://frmas.free.fr/li_1.htm#_Xrmap_"
-SRC_URI="ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${P}.tar.bz2
+FULL_DIST="2.10"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${PN}-${FULL_DIST}.tgz
+ ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${P}.tar.bz2
ftp://ftp.ac-grenoble.fr/ge/geosciences/CIA_WDB2.jpd.gz"
LICENSE="GPL-2"
@@ -18,6 +20,14 @@ DEPEND="media-gfx/imagemagick
>=sys-apps/sed-4
zlib? ( sys-libs/zlib )"
+src_unpack() {
+ unpack ${A}
+ rm -rf ${S}
+ mv ${WORKDIR}/${PN}-${FULL_DIST} ${S}
+ unpack ${A}
+ cd ${S}/editkit && xmkmf || die
+}
+
src_compile() {
use zlib || sed -i 's/-DZLIB\|-lz//g' Makefile.noimake || die
@@ -42,7 +52,7 @@ src_install() {
dobin xrmap tools/preproc tools/jpd2else/jpd2else tools/cbd2else/cbd2else || die
dodir /usr/share/${PN}/ || die
dodir /etc/xrmap || die
- cp -r {i18n,Locations,factbook,anthems,flags,hymns} ${D}/usr/share/${PN}/ || die
+ cp -r {i18n,Locations,factbook,anthems,flags,hymns,pixmaps} ${D}/usr/share/${PN}/ || die
cp Xrmaprc ${D}/etc/xrmap || die
cp ${WORKDIR}/CIA_WDB2.jpd ${D}/usr/share/${PN}/ || die
dodoc CHANGES COPYING README TODO WARNING tools/cbd2else/README.cbd tools/jpd2else/README.jpd tools/rez2else/README.rez || die