summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-03 19:02:05 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-03 19:02:05 +0000
commit68b7f6730399b80ea3fcc2ddd63c4241d94d738d (patch)
tree2c4a73c5b41e2977e4bcf38c8b8366736e2ee994 /x11-misc/xplanet
parentlibthrowable: fix for gcc43 (diff)
downloadgentoo-2-68b7f6730399b80ea3fcc2ddd63c4241d94d738d.tar.gz
gentoo-2-68b7f6730399b80ea3fcc2ddd63c4241d94d738d.tar.bz2
gentoo-2-68b7f6730399b80ea3fcc2ddd63c4241d94d738d.zip
Fix building with GCC 4.3 wrt #214047, thanks to Michal Kiedrowicz.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'x11-misc/xplanet')
-rw-r--r--x11-misc/xplanet/ChangeLog8
-rw-r--r--x11-misc/xplanet/files/xplanet-1.2.0-gcc43.patch135
-rw-r--r--x11-misc/xplanet/xplanet-1.2.0.ebuild12
3 files changed, 151 insertions, 4 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 275216ef9c40..52da91d47678 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xplanet
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.61 2007/07/01 04:38:36 drac Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.62 2008/05/03 19:02:05 drac Exp $
+
+ 03 May 2008; Samuli Suominen <drac@gentoo.org>
+ +files/xplanet-1.2.0-gcc43.patch, xplanet-1.2.0.ebuild:
+ Fix building with GCC 4.3 wrt #214047, thanks to Michal Kiedrowicz.
01 Jul 2007; Samuli Suominen <drac@gentoo.org> xplanet-1.2.0.ebuild:
Clean up.
diff --git a/x11-misc/xplanet/files/xplanet-1.2.0-gcc43.patch b/x11-misc/xplanet/files/xplanet-1.2.0-gcc43.patch
new file mode 100644
index 000000000000..210c8a638aa4
--- /dev/null
+++ b/x11-misc/xplanet/files/xplanet-1.2.0-gcc43.patch
@@ -0,0 +1,135 @@
+diff -ur xplanet-1.2.0.orig/src/buildPlanetMap.cpp xplanet-1.2.0/src/buildPlanetMap.cpp
+--- xplanet-1.2.0.orig/src/buildPlanetMap.cpp 2004-04-20 23:47:21.000000000 +0200
++++ xplanet-1.2.0/src/buildPlanetMap.cpp 2008-03-20 15:48:24.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <cmath>
+ #include <cstdio>
++#include <cstdlib>
+ #include <map>
+ using namespace std;
+
+diff -ur xplanet-1.2.0.orig/src/libannotate/addArcs.cpp xplanet-1.2.0/src/libannotate/addArcs.cpp
+--- xplanet-1.2.0.orig/src/libannotate/addArcs.cpp 2005-03-15 19:27:13.000000000 +0100
++++ xplanet-1.2.0/src/libannotate/addArcs.cpp 2008-03-20 15:44:58.000000000 +0100
+@@ -3,7 +3,7 @@
+ #include <fstream>
+ #include <sstream>
+ #include <map>
+-#include <string>
++#include <cstring>
+ #include <vector>
+ using namespace std;
+
+diff -ur xplanet-1.2.0.orig/src/libannotate/addMarkers.cpp xplanet-1.2.0/src/libannotate/addMarkers.cpp
+--- xplanet-1.2.0.orig/src/libannotate/addMarkers.cpp 2004-08-29 22:41:58.000000000 +0200
++++ xplanet-1.2.0/src/libannotate/addMarkers.cpp 2008-03-20 15:45:11.000000000 +0100
+@@ -5,7 +5,7 @@
+ #include <fstream>
+ #include <map>
+ #include <sstream>
+-#include <string>
++#include <cstring>
+ #include <vector>
+ using namespace std;
+
+diff -ur xplanet-1.2.0.orig/src/libannotate/addSatellites.cpp xplanet-1.2.0/src/libannotate/addSatellites.cpp
+--- xplanet-1.2.0.orig/src/libannotate/addSatellites.cpp 2004-07-23 02:46:20.000000000 +0200
++++ xplanet-1.2.0/src/libannotate/addSatellites.cpp 2008-03-20 15:45:23.000000000 +0100
+@@ -4,7 +4,7 @@
+ #include <fstream>
+ #include <map>
+ #include <sstream>
+-#include <string>
++#include <cstring>
+ #include <vector>
+ using namespace std;
+
+diff -ur xplanet-1.2.0.orig/src/libannotate/Icon.cpp xplanet-1.2.0/src/libannotate/Icon.cpp
+--- xplanet-1.2.0.orig/src/libannotate/Icon.cpp 2004-02-16 19:36:42.000000000 +0100
++++ xplanet-1.2.0/src/libannotate/Icon.cpp 2008-03-20 15:45:58.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include <sstream>
++#include <cstring>
+ using namespace std;
+
+ #include "findFile.h"
+diff -ur xplanet-1.2.0.orig/src/libplanet/Planet.cpp xplanet-1.2.0/src/libplanet/Planet.cpp
+--- xplanet-1.2.0.orig/src/libplanet/Planet.cpp 2005-06-14 20:04:05.000000000 +0200
++++ xplanet-1.2.0/src/libplanet/Planet.cpp 2008-03-20 15:46:53.000000000 +0100
+@@ -2,7 +2,7 @@
+ #include <cstdio>
+ #include <cctype>
+ #include <sstream>
+-#include <string>
++#include <cstring>
+ using namespace std;
+
+ #include "findFile.h"
+diff -ur xplanet-1.2.0.orig/src/libprojection/getProjection.cpp xplanet-1.2.0/src/libprojection/getProjection.cpp
+--- xplanet-1.2.0.orig/src/libprojection/getProjection.cpp 2005-06-13 17:13:11.000000000 +0200
++++ xplanet-1.2.0/src/libprojection/getProjection.cpp 2008-03-20 15:47:34.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <cctype>
+ #include <cstring>
++#include <cstdlib>
+ #include <sstream>
+ #include <vector>
+ using namespace std;
+diff -ur xplanet-1.2.0.orig/src/Map.cpp xplanet-1.2.0/src/Map.cpp
+--- xplanet-1.2.0.orig/src/Map.cpp 2005-06-15 01:40:46.000000000 +0200
++++ xplanet-1.2.0/src/Map.cpp 2008-03-20 15:48:01.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <map>
+ #include <sstream>
++#include <cstdlib>
+ #include <string>
+ using namespace std;
+
+diff -ur xplanet-1.2.0.orig/src/parseColor.cpp xplanet-1.2.0/src/parseColor.cpp
+--- xplanet-1.2.0.orig/src/parseColor.cpp 2004-11-23 18:49:48.000000000 +0100
++++ xplanet-1.2.0/src/parseColor.cpp 2008-03-20 15:49:23.000000000 +0100
+@@ -2,7 +2,8 @@
+ #include <fstream>
+ #include <map>
+ #include <sstream>
+-#include <string>
++#include <cstring>
++#include <cstdlib>
+ using namespace std;
+
+ #include "findFile.h"
+diff -ur xplanet-1.2.0.orig/src/PlanetProperties.h xplanet-1.2.0/src/PlanetProperties.h
+--- xplanet-1.2.0.orig/src/PlanetProperties.h 2005-04-02 02:43:06.000000000 +0200
++++ xplanet-1.2.0/src/PlanetProperties.h 2008-03-20 15:46:16.000000000 +0100
+@@ -1,7 +1,7 @@
+ #ifndef PLANETPROPERTIES_H
+ #define PLANETPROPERTIES_H
+
+-#include <string>
++#include <cstring>
+ #include <vector>
+
+ #include "body.h"
+diff -ur xplanet-1.2.0.orig/src/xplanet.cpp xplanet-1.2.0/src/xplanet.cpp
+--- xplanet-1.2.0.orig/src/xplanet.cpp 2004-09-09 17:46:05.000000000 +0200
++++ xplanet-1.2.0/src/xplanet.cpp 2008-03-20 15:50:21.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <clocale>
+ #include <cstdio>
++#include <cstdlib>
+ #include <iostream>
+ #include <map>
+ #include <sstream>
+diff -ur xplanet-1.2.0.orig/src/xpUtil.cpp xplanet-1.2.0/src/xpUtil.cpp
+--- xplanet-1.2.0.orig/src/xpUtil.cpp 2005-04-02 02:22:51.000000000 +0200
++++ xplanet-1.2.0/src/xpUtil.cpp 2008-03-20 15:50:06.000000000 +0100
+@@ -5,7 +5,8 @@
+ #include <ctime>
+ #include <iostream>
+ #include <sstream>
+-#include <string>
++#include <cstring>
++#include <cstdlib>
+ using namespace std;
+
+ #include <unistd.h>
diff --git a/x11-misc/xplanet/xplanet-1.2.0.ebuild b/x11-misc/xplanet/xplanet-1.2.0.ebuild
index 8022d5473ade..409a5584109d 100644
--- a/x11-misc/xplanet/xplanet-1.2.0.ebuild
+++ b/x11-misc/xplanet/xplanet-1.2.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.2.0.ebuild,v 1.12 2007/07/01 04:38:36 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-1.2.0.ebuild,v 1.13 2008/05/03 19:02:05 drac Exp $
+
+inherit eutils
DESCRIPTION="a program to render images of the earth into the X root window"
HOMEPAGE="http://xplanet.sourceforge.net"
@@ -26,6 +28,12 @@ DEPEND="${RDEPEND}
X? ( x11-proto/xproto
x11-proto/scrnsaverproto )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
local myconf