summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-13 00:58:43 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-13 00:58:43 +0000
commitc758ea19eb805a9591b6b3c20780cccfe4bd594f (patch)
treecb6c5d84125bb625710eb1c20ac7467836fdf166 /x11-misc/xnots
parentVersion bump and old version cleanup (diff)
downloadgentoo-2-c758ea19eb805a9591b6b3c20780cccfe4bd594f.tar.gz
gentoo-2-c758ea19eb805a9591b6b3c20780cccfe4bd594f.tar.bz2
gentoo-2-c758ea19eb805a9591b6b3c20780cccfe4bd594f.zip
Version bump, bug #254594, ebuild improved by Gautam Iyer.
(Portage version: 2.1.6.5/cvs/Linux 2.6.28-tuxonice x86_64)
Diffstat (limited to 'x11-misc/xnots')
-rw-r--r--x11-misc/xnots/ChangeLog7
-rw-r--r--x11-misc/xnots/xnots-0.2.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/xnots/ChangeLog b/x11-misc/xnots/ChangeLog
index 62c50668276d..c90c76a2bcfb 100644
--- a/x11-misc/xnots/ChangeLog
+++ b/x11-misc/xnots/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xnots
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnots/ChangeLog,v 1.3 2009/01/08 22:30:26 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnots/ChangeLog,v 1.4 2009/01/13 00:58:43 nelchael Exp $
+
+*xnots-0.2.1 (13 Jan 2009)
+
+ 13 Jan 2009; <nelchael@gentoo.org> +xnots-0.2.1.ebuild:
+ Version bump, bug #254594, ebuild improved by Gautam Iyer.
08 Jan 2009; <nelchael@gentoo.org> xnots-0.2.ebuild:
Depend on pango with X use flag enabled.
diff --git a/x11-misc/xnots/xnots-0.2.1.ebuild b/x11-misc/xnots/xnots-0.2.1.ebuild
new file mode 100644
index 000000000000..404b3c1fab22
--- /dev/null
+++ b/x11-misc/xnots/xnots-0.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnots/xnots-0.2.1.ebuild,v 1.1 2009/01/13 00:58:43 nelchael Exp $
+
+EAPI="2"
+
+inherit linux-info
+
+DESCRIPTION="A desktop sticky note program for the unix geek"
+HOMEPAGE="http://xnots.sourceforge.net"
+SRC_URI="mirror://sourceforge/xnots/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vim-syntax"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/pango[X]"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/renderproto
+ x11-proto/randrproto"
+
+src_compile() {
+ NO_DEBUG=1 emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr mandir=/usr/share/man install || die
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins etc/xnots.vim
+ fi
+}
+
+pkg_postinst() {
+ if ! linux_chkconfig_present INOTIFY; then
+ ewarn "Your kernel is compiled without INOTIFY support."
+ ewarn "xNots requires INOTIFY support to run."
+ ewarn "Please enable CONFIG_INOTIFY in your kernel config."
+ fi
+}