summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-03-16 22:00:58 +0000
committerUlrich Müller <ulm@gentoo.org>2008-03-16 22:00:58 +0000
commitd4c66b87aa7203f988a09dc5c1e10ae80db96953 (patch)
tree14abed5972a326c93ff60fa9d8f394ac4b12cc95 /x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
parentNew major release, includes new GIO and GChecksum APIs and some new URI helpe... (diff)
downloadgentoo-2-d4c66b87aa7203f988a09dc5c1e10ae80db96953.tar.gz
gentoo-2-d4c66b87aa7203f988a09dc5c1e10ae80db96953.tar.bz2
gentoo-2-d4c66b87aa7203f988a09dc5c1e10ae80db96953.zip
Remove calls to motif-config, fixes bug 211844.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild')
-rw-r--r--x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild b/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
index f3356be8739b..3849a4797558 100644
--- a/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
+++ b/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild,v 1.7 2006/01/21 17:55:49 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild,v 1.8 2008/03/16 22:00:58 ulm Exp $
inherit eutils
MY_P=${P/_p*}
@@ -15,15 +15,15 @@ LICENSE="as-is"
KEYWORDS="x86 ppc"
IUSE="truetype"
-DEPEND=">=x11-libs/openmotif-2.1.30
+DEPEND=">=x11-libs/openmotif-2.3.0-r1
truetype? ( media-libs/freetype )"
S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${MY_P}.tar.bz2
- cd ${S}
- epatch ${DISTDIR}/${P/_p/-patch}
+ cd "${S}"
+ epatch "${DISTDIR}/${P/_p/-patch}"
epatch "${FILESDIR}/${P}-gcc4.patch"
}
@@ -32,8 +32,8 @@ src_compile() {
# specifying the correct options for Gentoo.
local flags=""
- local incs="`motif-config --cflags`"
- local libs="`motif-config --libs` -lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE"
+ local incs=""
+ local libs="-lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE"
if use truetype ; then
flags="FTYPE_DEFS=\"-DHAVE_FREETYPE\""