summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-14 15:43:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-14 15:43:49 +0000
commitfbea49691b051578f0e3382272dff2a0fd37c321 (patch)
tree5327cee1f2d2591e703c6130988c5a6d31d3d00a /x11-misc/xlockmore
parentsunstudioexpress is no more (diff)
downloadgentoo-2-fbea49691b051578f0e3382272dff2a0fd37c321.tar.gz
gentoo-2-fbea49691b051578f0e3382272dff2a0fd37c321.tar.bz2
gentoo-2-fbea49691b051578f0e3382272dff2a0fd37c321.zip
Remove extra CC and CXX checks from configure.in to avoid #285262.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xlockmore')
-rw-r--r--x11-misc/xlockmore/ChangeLog6
-rw-r--r--x11-misc/xlockmore/files/xlockmore-5.29.1-configure.in.patch22
-rw-r--r--x11-misc/xlockmore/xlockmore-5.29.1.ebuild9
3 files changed, 34 insertions, 3 deletions
diff --git a/x11-misc/xlockmore/ChangeLog b/x11-misc/xlockmore/ChangeLog
index f54d991204ec..a2c5cc357861 100644
--- a/x11-misc/xlockmore/ChangeLog
+++ b/x11-misc/xlockmore/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xlockmore
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.81 2010/02/14 15:09:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.82 2010/02/14 15:43:49 ssuominen Exp $
+
+ 14 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ xlockmore-5.29.1.ebuild, +files/xlockmore-5.29.1-configure.in.patch:
+ Remove extra CC and CXX checks from configure.in to avoid #285262.
14 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
xlockmore-5.29.1.ebuild:
diff --git a/x11-misc/xlockmore/files/xlockmore-5.29.1-configure.in.patch b/x11-misc/xlockmore/files/xlockmore-5.29.1-configure.in.patch
new file mode 100644
index 000000000000..e69999c23497
--- /dev/null
+++ b/x11-misc/xlockmore/files/xlockmore-5.29.1-configure.in.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/show_bug.cgi?id=285262
+
+--- configure.in
++++ configure.in
+@@ -8,17 +8,7 @@
+ canonical=$host
+
+ AC_PROG_CC
+-dnl Check if C++ compiler is present. If not set CXX to the C-compiler used
+-dnl for the other compilations.
+-if test "$CC" = gcc; then
+- AC_CHECK_PROGS(CXX, $CCC g++ CC C++ c++ cxx cc++ xlC $CC, gcc)
+-else
+- AC_CHECK_PROGS(CXX, $CCC CC C++ g++ c++ cxx cc++ xlC $CC, gcc)
+-fi
+ AC_PROG_CXX
+-if test "${CXX}" = "xlC" ; then
+- CXXFLAGS="${CXXFLAGS} -+"
+-fi
+
+ dnl If you're using g++-2.95 or later and have old X11 includes, you may need
+ dnl to use "g++ -fpermissive" in the Makefiles
diff --git a/x11-misc/xlockmore/xlockmore-5.29.1.ebuild b/x11-misc/xlockmore/xlockmore-5.29.1.ebuild
index 104e8d7ac3dc..e493dc82833c 100644
--- a/x11-misc/xlockmore/xlockmore-5.29.1.ebuild
+++ b/x11-misc/xlockmore/xlockmore-5.29.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.29.1.ebuild,v 1.2 2010/02/14 15:09:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.29.1.ebuild,v 1.3 2010/02/14 15:43:49 ssuominen Exp $
EAPI=2
-inherit flag-o-matic pam
+inherit autotools eutils flag-o-matic pam
DESCRIPTION="Just another screensaver application for X"
HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
@@ -34,6 +34,11 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.in.patch
+ eautoreconf
+}
+
src_configure() {
local myconf=""