summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-06-10 06:58:04 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-06-10 06:58:04 +0000
commitcfe42f67f04681d4d4b8a289b8d26cb417f9b55c (patch)
tree3407eae00f3b599138a7a6d14e33c70776f6cabd /x11-misc/xkeyboard-config
parentBump to latest. Should all be compatible with xorg-server-1.5. (diff)
downloadgentoo-2-cfe42f67f04681d4d4b8a289b8d26cb417f9b55c.tar.gz
gentoo-2-cfe42f67f04681d4d4b8a289b8d26cb417f9b55c.tar.bz2
gentoo-2-cfe42f67f04681d4d4b8a289b8d26cb417f9b55c.zip
Bump. Around 40 bugs from freedesktop.org bugzilla were fixed. Dropped old rulesets sgi and sun. Added a lot of metadata, related to countries and languages.
(Portage version: 2.1.5.4)
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog10
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-1.3.ebuild52
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index bff6448ac310..517c1c5aa39d 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.49 2008/03/19 19:10:36 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.50 2008/06/10 06:58:04 dberkholz Exp $
+
+*xkeyboard-config-1.3 (10 Jun 2008)
+
+ 10 Jun 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xkeyboard-config-1.3.ebuild:
+ Bump. Around 40 bugs from freedesktop.org bugzilla were fixed. Dropped old
+ rulesets sgi and sun. Added a lot of metadata, related to countries and
+ languages.
19 Mar 2008; Samuli Suominen <drac@gentoo.org>
xkeyboard-config-1.2.ebuild:
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-1.3.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-1.3.ebuild
new file mode 100644
index 000000000000..f8e7f57a5c96
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-1.3.ebuild,v 1.1 2008/06/10 06:58:04 dberkholz Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="X keyboard configuration database"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+SRC_URI="http://xlibs.freedesktop.org/xkbdesc/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="x11-apps/xkbcomp
+ !x11-misc/xkbdata"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser"
+
+pkg_setup() {
+ # (#130590) The old XKB directory can screw stuff up
+ local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
+ if [[ -d ${DIR} ]] ; then
+ eerror "Directory ${DIR} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${DIR}"
+ fi
+
+ # The old xkbdata 'pc' directory can screw stuff up, because portage won't
+ # let us overwrite a directory with a file
+ local PC="${ROOT}usr/share/X11/xkb/symbols/pc"
+ if [[ -d ${PC} ]] ; then
+ eerror "Directory ${PC} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${PC}"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --enable-compat-rules \
+ --disable-xkbcomp-symlink \
+ --with-xkb-rules-symlink=xorg \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}