summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAbhishek Amit <abhishek@gentoo.org>2003-11-25 05:06:50 +0000
committerAbhishek Amit <abhishek@gentoo.org>2003-11-25 05:06:50 +0000
commit2c9cd4ef153b6d6506bd78ad936978a2ca09c2b1 (patch)
treea633645a24e9038620739de82a13b62526d8385c /x11-misc/xkbd/xkbd-0.8.12.ebuild
parentInitial import. Ebuild submitted by Rene Wagner <reenoo@gmx.de> (diff)
downloadgentoo-2-2c9cd4ef153b6d6506bd78ad936978a2ca09c2b1.tar.gz
gentoo-2-2c9cd4ef153b6d6506bd78ad936978a2ca09c2b1.tar.bz2
gentoo-2-2c9cd4ef153b6d6506bd78ad936978a2ca09c2b1.zip
Initial import. Ebuild submitted by Rene Wagner <reenoo@gmx.de>
Diffstat (limited to 'x11-misc/xkbd/xkbd-0.8.12.ebuild')
-rw-r--r--x11-misc/xkbd/xkbd-0.8.12.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xkbd/xkbd-0.8.12.ebuild b/x11-misc/xkbd/xkbd-0.8.12.ebuild
new file mode 100644
index 000000000000..884e74aad6ff
--- /dev/null
+++ b/x11-misc/xkbd/xkbd-0.8.12.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbd/xkbd-0.8.12.ebuild,v 1.1 2003/11/25 05:06:32 abhishek Exp $
+
+DESCRIPTION="Xkbd - onscreen soft keyboard for X11"
+HOMEPAGE="http://handhelds.org/~mallum/xkbd/"
+SRC_URI="http://handhelds.org/~mallum/xkbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="x86"
+
+IUSE="doc debug"
+
+DEPEND="sys-devel/libtool
+ virtual/x11
+ media-libs/freetype
+ virtual/xft
+ dev-libs/expat
+ sys-libs/zlib
+ doc? ( app-text/docbook-sgml-utils )"
+
+#RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf\
+ `use_enable debug`
+
+ emake || die
+
+ if [ `use doc` ]; then
+ docbook2html README
+ fi
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING NEWS README
+
+ if [ `use doc` ]; then
+ insinto /usr/share/doc/${PF}/html
+ doins *.html
+ fi
+}