summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-10-15 22:56:21 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-10-15 22:56:21 +0000
commit9dce4a194daeeab68cced72b059d17bf312603e7 (patch)
tree9d6fa333bbc57a34397ad93abc9f08ace8edda5f /x11-misc/xfe/xfe-0.72.ebuild
parentadd one file that the ivtv ebuild doesn't install (Manifest recommit) (diff)
downloadgentoo-2-9dce4a194daeeab68cced72b059d17bf312603e7.tar.gz
gentoo-2-9dce4a194daeeab68cced72b059d17bf312603e7.tar.bz2
gentoo-2-9dce4a194daeeab68cced72b059d17bf312603e7.zip
Bump x11-misc/xfe to version 0.72. Closes #66935
Diffstat (limited to 'x11-misc/xfe/xfe-0.72.ebuild')
-rw-r--r--x11-misc/xfe/xfe-0.72.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xfe/xfe-0.72.ebuild b/x11-misc/xfe/xfe-0.72.ebuild
new file mode 100644
index 000000000000..db539ca12117
--- /dev/null
+++ b/x11-misc/xfe/xfe-0.72.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.72.ebuild,v 1.1 2004/10/15 22:56:21 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="MS-Explorer like file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE="nls"
+
+# fox-1.0.x, fox-1.1.x and fox-1.3.x are incompatible.
+DEPEND="=x11-libs/fox-1.2*"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Fix #62428. Note: this 0.70 related bug is STILL present in 0.72...
+ epatch ${FILESDIR}/xfe-0.70-file-association.patch
+}
+
+src_compile()
+{
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install()
+{
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS FAQ README TODO NEWS
+}
+
+pkg_postinst()
+{
+ einfo
+ einfo "Please delete your old Xfe registry files"
+ einfo " (~/.foxrc/Xfe ~/.foxrc/Xfv and ~/.foxrc/Xfq)"
+ einfo "before using this XFE 0.72 release"
+ einfo
+}