summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-11-18 04:18:54 +0000
committerIan Leitch <port001@gentoo.org>2003-11-18 04:18:54 +0000
commit7ac76200a3a6f594f83629b768574d2d36078538 (patch)
treee0c738140828175e6937a256cb845d220a36c648 /x11-misc/xearth/xearth-1.1.ebuild
parentmoved from app-misc to x11-misc, metadata created (diff)
downloadgentoo-2-7ac76200a3a6f594f83629b768574d2d36078538.tar.gz
gentoo-2-7ac76200a3a6f594f83629b768574d2d36078538.tar.bz2
gentoo-2-7ac76200a3a6f594f83629b768574d2d36078538.zip
moved from app-misc to x11-misc, metadata created
Diffstat (limited to 'x11-misc/xearth/xearth-1.1.ebuild')
-rw-r--r--x11-misc/xearth/xearth-1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/xearth/xearth-1.1.ebuild b/x11-misc/xearth/xearth-1.1.ebuild
new file mode 100644
index 000000000000..7a7442d48e2e
--- /dev/null
+++ b/x11-misc/xearth/xearth-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xearth/xearth-1.1.ebuild,v 1.1 2003/11/18 04:18:50 port001 Exp $
+
+HOMEPAGE="http://www.cs.colorado.edu/~tuna/xearth/"
+DESCRIPTION="Xearth sets the X root window to an image of the Earth"
+SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
+ ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="xearth"
+KEYWORDS="x86 sparc ppc"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+ xmkmf || die
+ mv Makefile Makefile.orig
+ sed -e "s:CDEBUGFLAGS = .*:CDEBUGFLAGS = ${CFLAGS} -fno-strength-reduce:" \
+ Makefile.orig > Makefile
+ emake || die
+}
+
+src_install() {
+ newman xearth.man xearth.1
+ dobin xearth
+ dodoc BUILT-IN GAMMA-TEST HISTORY INSTALL README
+}