summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-11-05 09:45:49 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-11-05 09:45:49 +0000
commit22c0cb6e0a26bb6396cbc5cc78ae528ffad571d0 (patch)
tree6a449a57f2b9295d707f7a00fbed4c37dbb99407 /x11-misc/xcape
parentMask "ConsoleKit2" for testing. (diff)
downloadgentoo-2-22c0cb6e0a26bb6396cbc5cc78ae528ffad571d0.tar.gz
gentoo-2-22c0cb6e0a26bb6396cbc5cc78ae528ffad571d0.tar.bz2
gentoo-2-22c0cb6e0a26bb6396cbc5cc78ae528ffad571d0.zip
Version bump, wrt bug #527860. Fix manpage installation path, use correct pkg-config, add support for Gentoo Prefix
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'x11-misc/xcape')
-rw-r--r--x11-misc/xcape/ChangeLog10
-rw-r--r--x11-misc/xcape/xcape-1.1.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/x11-misc/xcape/ChangeLog b/x11-misc/xcape/ChangeLog
index 243818fe7159..52231da432ad 100644
--- a/x11-misc/xcape/ChangeLog
+++ b/x11-misc/xcape/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xcape
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/ChangeLog,v 1.1 2013/03/10 08:50:29 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/ChangeLog,v 1.2 2014/11/05 09:45:49 pinkbyte Exp $
+
+*xcape-1.1 (05 Nov 2014)
+
+ 05 Nov 2014; Sergey Popov <pinkbyte@gentoo.org> +xcape-1.1.ebuild:
+ Version bump, wrt bug #527860. Fix manpage installation path, use correct
+ pkg-config, add support for Gentoo Prefix
*xcape-1.0 (10 Mar 2013)
diff --git a/x11-misc/xcape/xcape-1.1.ebuild b/x11-misc/xcape/xcape-1.1.ebuild
new file mode 100644
index 000000000000..95feeed346f7
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/xcape-1.1.ebuild,v 1.1 2014/11/05 09:45:49 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix path to man and to pkg-config
+ sed -i \
+ -e "/MANDIR/s:local:share:" \
+ -e "s/pkg-config/$(tc-getPKG_CONFIG)/" \
+ Makefile || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}