summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-02-19 04:45:14 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-02-19 04:45:14 +0000
commit7f35fc3772342c4aa01ea1510b7dabc92fda0166 (patch)
tree70eeeeb1114916a43f28bed1d06706fa27ab5262 /x11-misc/xac/xac-0.6_pre3.ebuild
parentAdd back hal_unmount that was accidently removed (diff)
downloadgentoo-2-7f35fc3772342c4aa01ea1510b7dabc92fda0166.tar.gz
gentoo-2-7f35fc3772342c4aa01ea1510b7dabc92fda0166.tar.bz2
gentoo-2-7f35fc3772342c4aa01ea1510b7dabc92fda0166.zip
More bug fixes, removed init scripts when not building for a livecd.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'x11-misc/xac/xac-0.6_pre3.ebuild')
-rw-r--r--x11-misc/xac/xac-0.6_pre3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/xac/xac-0.6_pre3.ebuild b/x11-misc/xac/xac-0.6_pre3.ebuild
new file mode 100644
index 000000000000..0f2f8adc8ac6
--- /dev/null
+++ b/x11-misc/xac/xac-0.6_pre3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/xac-0.6_pre3.ebuild,v 1.1 2007/02/19 04:45:14 josejx Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
+HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="livecd"
+DEPEND=">=dev-lang/python-2.3
+ sys-apps/pciutils"
+RDEPEND=">=dev-lang/python-2.3
+ || ( x11-base/xorg-server virtual/x11 )"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ ### Replace /usr/lib/xac with libdir version
+ sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
+}
+
+src_compile() {
+ ### Compile the C bindings
+ cd "${S}"/src
+ ### I'm not sure of a better way to do this yet
+ if use x86; then
+ sed -i "s:if 1:if 0:" setup.py || die "Enabling VBE module failed!"
+ fi
+ ./setup.py build || die "Failed to build the C modules"
+}
+
+src_install() {
+ local xac_base="/usr/$(get_libdir)/xac"
+
+ dosbin "${S}"/xac
+
+ ### Install the C mods
+ cd "${S}"/src
+ ./setup.py install --root "${D}" || die "Failed to install the C modules"
+
+ dodir "${xac_base}"
+ insinto ${xac_base}
+ doins "${S}"/py/*
+
+ ### Only install the init scripts if livecd is enabled
+ if use livecd; then
+ exeinto /etc/init.d
+ newexe "${S}"/xac.init xac
+ insinto /etc/conf.d
+ newins "${S}"/xac.conf xac
+ fi
+}