summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2010-03-14 20:56:11 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2010-03-14 20:56:11 +0000
commit4f1bb1affe114b938e7f95ffa2817485840dd869 (patch)
treecd86ed19cf2cca8c06992617fc61c7c54214aa96 /x11-misc/x2vnc
parentAdd fixes for python/tcl bindings and python.eclass fixes by Thomas Beierlein (diff)
downloadgentoo-2-4f1bb1affe114b938e7f95ffa2817485840dd869.tar.gz
gentoo-2-4f1bb1affe114b938e7f95ffa2817485840dd869.tar.bz2
gentoo-2-4f1bb1affe114b938e7f95ffa2817485840dd869.zip
Little workaround for broken expectk binary, see bug #308713.
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'x11-misc/x2vnc')
-rw-r--r--x11-misc/x2vnc/ChangeLog8
-rw-r--r--x11-misc/x2vnc/files/expectk.patch17
-rw-r--r--x11-misc/x2vnc/x2vnc-1.6.1.ebuild6
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild37
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2.ebuild6
5 files changed, 67 insertions, 7 deletions
diff --git a/x11-misc/x2vnc/ChangeLog b/x11-misc/x2vnc/ChangeLog
index b1b9b88f70da..71b3a37771a9 100644
--- a/x11-misc/x2vnc/ChangeLog
+++ b/x11-misc/x2vnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/x2vnc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/ChangeLog,v 1.34 2010/03/09 20:30:41 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/ChangeLog,v 1.35 2010/03/14 20:56:09 phosphan Exp $
+
+*x2vnc-1.7.2-r1 (14 Mar 2010)
+
+ 14 Mar 2010; Patrick Kursawe <phosphan@gentoo.org> +x2vnc-1.7.2-r1.ebuild,
+ +files/expectk.patch:
+ Little workaround for broken expectk binary, see bug #308713.
09 Mar 2010; Patrick Kursawe <phosphan@gentoo.org> -x2vnc-1.7.1.ebuild:
Removing obsolete revision.
diff --git a/x11-misc/x2vnc/files/expectk.patch b/x11-misc/x2vnc/files/expectk.patch
new file mode 100644
index 000000000000..5c5ba6887cb1
--- /dev/null
+++ b/x11-misc/x2vnc/files/expectk.patch
@@ -0,0 +1,17 @@
+--- tkx2vnc 2010-03-14 21:31:49.000000000 +0100
++++ tkx2vnc.new 2010-03-14 21:32:58.000000000 +0100
+@@ -1,10 +1,13 @@
+-#!/usr/bin/expectk -f
++#!/usr/bin/wish
+
+ # Name: tkx2vnc
+ # Author: David Noble
+ # Version: 1.0a
+ # Written: May 13, 2002
+ # Modified: May 15, 2002
++# Expect dependency fixed by Patrick Kursawe, March 14, 2010
++
++package require Expect
+
+ proc prompt {} {
+ global prefs
diff --git a/x11-misc/x2vnc/x2vnc-1.6.1.ebuild b/x11-misc/x2vnc/x2vnc-1.6.1.ebuild
index e5e202da1bd6..703993b92cc9 100644
--- a/x11-misc/x2vnc/x2vnc-1.6.1.ebuild
+++ b/x11-misc/x2vnc/x2vnc-1.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.6.1.ebuild,v 1.9 2007/07/22 03:35:05 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.6.1.ebuild,v 1.10 2010/03/14 20:56:09 phosphan Exp $
DESCRIPTION="Control a remote computer running VNC from X"
HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
src_install() {
dodir /usr/share /usr/bin
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
use tk && dobin contrib/tkx2vnc
dodoc ChangeLog README
}
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..2a9b5cf5fc5c
--- /dev/null
+++ b/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild,v 1.1 2010/03/14 20:56:09 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="Control a remote computer running VNC from X"
+HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
+SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="tk"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXext
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+ x11-proto/xineramaproto
+ tk? ( dev-tcltk/expect )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/contrib"
+ epatch "${FILESDIR}/expectk.patch"
+}
+
+src_install() {
+ dodir /usr/share /usr/bin
+ make DESTDIR="${D}" install || die
+ use tk && dobin contrib/tkx2vnc
+ dodoc ChangeLog README
+}
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2.ebuild
index b18e52f52dd5..e88a2835c0fb 100644
--- a/x11-misc/x2vnc/x2vnc-1.7.2.ebuild
+++ b/x11-misc/x2vnc/x2vnc-1.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.7.2.ebuild,v 1.3 2007/07/22 03:35:05 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x2vnc/x2vnc-1.7.2.ebuild,v 1.4 2010/03/14 20:56:09 phosphan Exp $
DESCRIPTION="Control a remote computer running VNC from X"
HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
src_install() {
dodir /usr/share /usr/bin
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
use tk && dobin contrib/tkx2vnc
dodoc ChangeLog README
}