summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-22 20:52:34 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-22 20:52:34 +0000
commit1098c0a681d4de8c0c71751ef6c33acf38ca06e3 (patch)
treeeba67cf46df4cce4f9de077d8ecee2bf68d10bcc /x11-misc/ttmkfdir
parentAdded bug# to changelog. (Manifest recommit) (diff)
downloadgentoo-2-1098c0a681d4de8c0c71751ef6c33acf38ca06e3.tar.gz
gentoo-2-1098c0a681d4de8c0c71751ef6c33acf38ca06e3.tar.bz2
gentoo-2-1098c0a681d4de8c0c71751ef6c33acf38ca06e3.zip
gcc 3.4 fix
Diffstat (limited to 'x11-misc/ttmkfdir')
-rw-r--r--x11-misc/ttmkfdir/ChangeLog6
-rw-r--r--x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-gcc34.patch35
-rw-r--r--x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild3
3 files changed, 42 insertions, 2 deletions
diff --git a/x11-misc/ttmkfdir/ChangeLog b/x11-misc/ttmkfdir/ChangeLog
index 3861b0f99cf2..cba73ca69224 100644
--- a/x11-misc/ttmkfdir/ChangeLog
+++ b/x11-misc/ttmkfdir/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/ttmkfdir
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ChangeLog,v 1.30 2004/04/13 11:51:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ChangeLog,v 1.31 2004/04/22 20:52:34 lv Exp $
+
+ 22 Apr 2004; Travis Tilley <lv@gentoo.org>
+ +files/ttmkfdir-3.0.9-gcc34.patch, ttmkfdir-3.0.9-r1.ebuild:
+ added fix for compiling with gcc 3.4
13 Apr 2004; Guy Martin <gmsoft@gentoo.org> ttmkfdir-3.0.9-r1.ebuild:
Marked stable on hppa.
diff --git a/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-gcc34.patch b/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-gcc34.patch
new file mode 100644
index 000000000000..7df899ef2e59
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/ttmkfdir-3.0.9-gcc34.patch
@@ -0,0 +1,35 @@
+diff -Nurd builtin.cpp.old builtin.cpp
+--- builtin.cpp.old 2004-04-22 16:26:16.175065656 -0400
++++ builtin.cpp 2004-04-22 16:27:06.042484656 -0400
+@@ -600,7 +600,7 @@
+ 0x00f8, 0x00f9, 0x00fa, 0x00fb, 0x00fc, 0x00fd, 0x00fe, 0x00ff
+ };
+
+-};
++}
+
+ Encoding::BuiltinEncoding_t Encoding::builtin_encodings[] = {
+ {256,191,32,{TT_PLATFORM_MICROSOFT,TT_MS_ID_UNICODE_CS,iso8859_1},{"iso8859-1",}},
+diff -Nurd ttf.h.old ttf.h
+--- ttf.h.old 2004-04-22 16:26:16.176065504 -0400
++++ ttf.h 2004-04-22 16:27:06.042484656 -0400
+@@ -49,7 +49,7 @@
+ TT_Postscript *post;
+ std::string FileName;
+ };
+-};
++}
+
+ #endif /* TTF_H__ */
+
+diff -Nurd util.h.old util.h
+--- util.h.old 2004-04-22 16:26:16.176065504 -0400
++++ util.h 2004-04-22 16:27:06.042484656 -0400
+@@ -17,6 +17,6 @@
+ Singleton (void) {};
+ ~Singleton (void) {};
+ };
+-};
++}
+
+ #endif // TTMKFDIRUTIL_H__
diff --git a/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild b/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild
index aaad1635467b..7fe280e470c5 100644
--- a/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild
+++ b/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild,v 1.9 2004/04/13 11:51:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ttmkfdir-3.0.9-r1.ebuild,v 1.10 2004/04/22 20:52:34 lv Exp $
inherit eutils flag-o-matic
@@ -26,6 +26,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-cpp.patch
epatch ${FILESDIR}/${P}-zlib.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {